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Preface

Conventions
The information in this guide follows certain conventions that are adopted to
assist you in locating and identifying the information. These conventions are
broken down into two sections:

Keyboard conventions
These conventions are made up of key combinations and key sequences.
Notation

Meaning

<Key1+Key2>

The plus sign (+) between Key1 and Key2 means that both keys have to
be pressed simultaneously. For example, “Press<Control+Z>” means that
the <Control>and<Z>keys have to be pressed at the same time.

<Key1,Key2>

The comma (,) between Key1 and Key2 means that the keys have to be
pressed in sequence. For example, “Press <C,Return>” means that you
press the <C> key and release it, and then press the <Return> key and
release it.

<>

The characters enclosed in this “bracket” represent any of the symbols,
letters and key names on the keyboard.

[]

The square bracket is used for indicating the optional parameters.

v

Document conventions
These conventions are adopted to provide consistent text formats and cues,
and are designed to ensure that information is easily identifiable.
Type style

Used for

Italic

Italic type is used for indicating any text supplied by you.

Courier font

Command names, switches and any text that must be presented exactly
as it appears.

ALL CAPITALS

Directory names, filenames, and acronyms.

Notices
Three levels of notices might be used in this guide. They are as follows:
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Levels

Used for

Note

Used to emphasize an area of text.

Caution

Used to warn of undesirable procedures or of situations in which
equipment damage could potentially result.

Important

Used to denote an area of text where the information/instructions must not
be taken lightly but should be noted/followed.
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Voice Utilities

This chapter includes information on the following:
m Playing Sound Files
m Adding Voice File Header
m Converting Voice Files to Waveform Files
m Converting Waveform Files to Voice Files
m Converting Between Version 1.10 and 1.20 Voice Files

1

Several voice utilities are provided for various multimedia applications. All of
these files are located in /SB16/VOCUTIL. These utilities are as follows:
Voice utilities

Uses for

VPLAY

Plays digitized voice in VOC format

WPLAY

Plays digitized voice in WAV format

VOCHDR

Adds headers to raw voice files

VOC2WAV

Converts voice files to waveform files

WAV2VOC

Converts waveform files to voice files

VOCO2N

Converts Version 1.10 voice files to Version 1.20

VOCN20

Converts Version 1.20 voice files to Version 1.10

Note: VOC is the Creative voice file extension and WAV is the Microsoft
wave file extension.
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Playing sound files
The VPLAY and WPLAY utilities are for playing voice files from the DOS
command line. The voice file must be in VOC or WAV format.
The command line entry for VPLAY is:
VPLAY file.voc [/B:xx] [/T:xx] [/Q] [/X="command line"]

The command line entry for WPLAY is:
WPLAY file.wav [/B:xx] [/T:xx] [/Q] [/X="command line"]

Parameter specifications
The following are the command line parameters for VPLAY and WPLAY:
Parameter

Description

file

The voice or waveform file to play.

/B:xx

Sets the buffer size for playback.
xx is the size of the buffer in 2 Kbyte units. If the buffer size is not
specified, a default value of 16 is assumed for xx (32 Kbytes per buffer).
xx ranges from 2 to 32.

/T:xx

Limits the playback time in one second units.
xx ranges form 1 to 65535. (Note: This function will not work when the
/X switch is specified.)

/Q

Specifies a quiet screen operation mode.
All messages except error messages are suppressed when this is
specified.

/X="command line"

Executes a DOS command or another program once the voice process is
activated. (It is necessary to include the quotation marks when using this
command.)

Voice Utilities
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Adding voice file header
The VOCHDR utility adds the .VOC header to a file containing raw sound
data. With the header, programs using the CT-VOICE or CTVDSK driver can
play the voice file.
The command line entry for this utility is:
VOCHDR source target.voc [/S:xxxxx] [/T:x] [/R:xx] [/C:x] [/O]
[/? or /H]

Parameter specifications
The following are the command line parameters:

4

Chapter 1

Parameter

Description

/S:xxxxx

Specifies the sampling rate.
If value is not specified for xxxxx, the default value of 22050 Hz is used.

/T:x

Defines the type of raw voice data file. x can be either 1 for mono or 2 f
or stereo.

/R:xx

Specifies the number of bits per sample. Type 8 for 8 bits per sample and
16 for 16 bits per sample. The default is 8.

/C:x

Defines the compression method used. Valid values to use are 4, 3, 2,
and 0. The default is 0.

/O

Generates Version 1.10 voice files. If this is omitted, version 1.20 files
are generated.

/? or /H

Displays the help screen.

Converting voice files to waveform files
The VOC2WAV utility is for converting files with VOC format to WAV
format.
The command line entry for this utility is:
VOC2WAV source [target] [/Cxx] [/Rxx] [/Sxx] [/Lxx]

Parameter specifications
Parameter

Description

/Cxx

Specifies the audio channels.
xx can be either 1 for mono or 2 for stereo. Default is 1.

/Rxx

Sets sampling rate for the waveform file.
xx can be 11, 22, or 44 kHz. Default is 11 kHz.

/Sxx

Converts silence block from voice file to waveform file data block. xx is
either OFF or ON. Default is OFF.

/Lxx

Replicates the voice data between the Repeat and End Repeat statement
in a voice file to a waveform file. xx is either OFF or ON. Default is OFF.

Note: VOC2WAV will process versions 1.10 and 1.20 voice files alike.

Voice Utilities
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Examples
The following are examples of converting voice files to waveform files.
VOC2WAV sample.voc

Performs a default conversion.
VOC2WAV sample.voc newsamp.wav /C2

Performs a stereo conversion.
VOC2WAV sample.voc repsamp.wav /C2 /LON

Performs a conversion with repeat blocks expanded. If sample.voc has the
following format:
VOC Header

Repeat 2
VOCdata
End Repeat
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The output file (repsamp.wav) will have the following data:
WAV Header

wave data
wave data
wave data
Note: Remember the following points when converting from VOC file format
to WAV:
m WAV file formats only support 11, 22, and 44 kHz sampling rates. All voice
files are converted based on these rates.
m WAV file format supports only one block of data and can be played at only
one sampling rate. Therefore, the source voice files should only contain
blocks with the same sampling rate.
m Compressed voice file data blocks are not converted.

Voice Utilities
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Converting waveform files to voice files
The WAV2VOC utility is for converting files in WAV format to VOC format.
The command line entry for this utility is:
WAV2VOC source [target] [/O] [/8]

Parameter specifications
The following are the parameter specifications for WAV2VOC:
Parameter

Description

/O

Generates Version 1.10 VOC file format. The default is the 1.20 file format.

/8

Converts 16 bit WAV to 8 bit VOC. The default is the original number of
bits used in WAV.

Note: DOS wildcards (*,?) may be specified for the source file. Using the
wildcard, the target file will retain the same name as the source file but with
the VOC extension.
Examples
The following are examples of converting waveform files to voice files.
WAV2VOC wavsamp.wav

Converts the file wavsamp.wav to wavsamp.voc.
WAV2VOC *.wav

Converts all waveform files to voice files. The converted file will have the
same name but with a voc extension.
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Converting between version 1.10 and 1.20 voice files
The utilities that allow you to convert between Version 1.10 and 1.20 voice
files are VOCO2N and VOCN20.
To convert a version 1.10 voice file to version 1.20, the command line entry is:
VOCO2N file1 file2

To convert a version 1.20 voice file to version 1.10, the command line entry is:
VOCN2O file1 file2. (The /M switch in VOCN20 allows you to convert stereo
files to mono.)

Parameter specifications
The following are the command line parameters for both utilities:
Parameter

Description

file1

Represents the input file.

file2

Represents the output file.

Note: All specified files must have the VOC extension. If no files are
specified, a short help will be displayed. Version 1.20 format supports
16-bit data.

Voice Utilities
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Music Utility

PLAYMIDI utility
PLAYMIDI plays standard MIDI files in the DOS environment. Before
running the utility, you have to load the SBMIDI driver into memory.
To load SBMIDI into memory:
1

Change to \SB16 directory.

2

Type SBMIDI [/G | /E | /B] [/U] [/?].

3

Press <Enter>.

The parameters for SBMIDI are as follows:
Parameter

Description

/G, /E or /B

Sets the MIDI format in use.
/G denotes General MIDI format which plays all 16 channels with channel
10 as the drum channel.
/E denotes Extended MIDI format which plays the first 10 channels with
channel 10 as the drum channel. This is the default format.
/B denotes Basic MIDI format which plays from channels 13 to 16 with
channel 16 as the drum channel.

/U

Unloads the SBMIDI driver.

/?

Provides on-line help messages.
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SBMIDI displays the actual settings when it is first loaded. If you wish to
change the settings, run SBMIDI again with the desired settings. To show the
current settings, run SBMIDI without any parameters.
To play MIDI files:
1

Change to \SB16\PLAYMIDI directory.

2

Type PLAYMIDI midifile [/FMT:type] [/DRUM:channel] [/S:command]
[/Q][/?].

3

Press <Enter>.

The parameters for PLAYMIDI are as follows:
Parameter

Description

/FMT:type

Enter Basic, General, or Extended to play a MIDI file in the format of your
choice. The default follows the SBMIDI settings.

/DRUM:channel

Defines the drum channel. The default is channel 10.

/S:command

Runs a DOS command while playing a MIDI file.

/Q

Plays a MIDI file without messages on the screen.

/?

Provides on-line help messages.

Note: To exit PLAYMIDI, press the Esc key.
Example
To play JAZZ.MID in Extended format and Basic format, the command line
entries are PLAYMIDI JAZZ /FMT:EXTENDED and PLAYMIDI JAZZ
/FMT:BASIC.
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Mixer Utilities

Read this chapter to learn how to use the mixer utilities, including
information on:
m Running MIXERSET Utility
m Controlling Options Using the Mouse or Keyboard

13

Running MIXERSET utility
MIXERSET controls the Mixer using an on-screen mixer or from the
DOS command line.
To run the MIXERSET:
1

Change to \SB16 directory.

2

Type MIXERSET and press <Enter>

3

To exit from the mixer, click the button on the top left-hand corner of the on-screen mixer
or press <Esc>.

Note: The DOS mouse driver needs to be installed before it can be used in
this mode. If you have a mouse driver, type Mouse at the DOS prompt and
press <Enter> to install it.

Controlling options using the mouse or keyboard
You can use the mouse or the keyboard to control the various options on the
Mixer.
When using the mouse to control an option:
m Select the option if it is a check box.
m Move the scroll box by dragging it or clicking a scroll arrow to increase or
decrease the volume/tone.
When using the keyboard to control an option:
m Use <Tab> to move to the option.
m Use <Spacebar> to select the option if it is in a check box.
m Use the right or left arrow key to increase or decrease the volume/tone.
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FM Intelligent Organ

Read this chapter to learn about the following features of FM Organ:
m Loading FM Organ
m Octaves on FM Organ
m Loading a Song
m Learning a Song
m Playing FM Organ
m Saving, Loading, and Replaying a Song
m Adding Accompaniment to Songs
m Changing Instruments and Rhythms
m Changing Default Settings

15

FM Intelligent Organ
FM Organ is a DOS-based application that can transform your computer into
an organ and you into an instant musician. With this program, you can learn
to play complex musical pieces on your computer keyboard. FM Organ also
has a function to help you master the organ. And if you have a MIDIcompatible keyboard, using the MIDI interface on your audio card will
increase your music-making capabilities tenfold.

Loading FM Organ
To load FM Organ:
1

Change to \SB16\PRO_ORG sub-directory.

2

Type PRO_ORG and press <Enter>.

The FM Organ main menu similar to Figure 4-1 appears.

Figure 4-1 The FM Organ main menu.
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Octaves on FM Organ
Like any organ keyboard, the keys on FM Organ are arranged in groups of 12
keys (5 black and 7 white keys). Each group is called an octave and the first
white key of each octave is “DO,” the second “RE,” the third “MI,” and so on.
The Middle C is the “DO” note of the D octave.
There are seven octaves on FM Organ. For convenience, they are named A, B,
C, D, E, F, and G (see Figure 4-2). Only four octaves can be accessed from the
PC keyboard at one time. To access the rest of the octaves, use the right or left
arrow key (when in play mode only).
The green bar above FM Organ indicates the four octaves. The four octaves
represent the four rows of keys on your PC keyboard, that is rows 1, Q, A, and
Z, that are used for playing FM Organ. If the D octave is shifted to the far-left
of the green bar, then row Z would represent the D octave. On the other hand,
if the D octave is shifted to the far-right, then row 1 would represent the D
octave (see Figure 4-2).

Figure 4-2 Seven octaves of FM Organ on the PC keyboard.

FM Intelligent Organ
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The four octaves do not allow you to make use of the black keys on the
keyboard. If you want to make use of the black keys, press <Tab>. When
<Tab> is pressed, the four rows on the keyboard will only comprise two
octaves, namely D and E (see Figure 4-3).

Figure 4-3: The D and E octaves on the PC keyboard.

Loading a song
To load a song, first return to the main menu. Then follow these steps:
1

Press <F6>.

A window listing the available songs appears below FM Organ.
2

Use <Page Up>, <Page Down>, or the arrow keys to select a song.

Note: <Page Up> and <Page Down> are used for moving between different
groups of songs, while the arrow keys are used for selecting a particular song
within a group.
3

Press <Enter>.

4

Press <F4> to play the song.

Note: If you press <F2> instead of <F4> to play the song, you will hear the
accompaniment and not the melody. To hear the melody, the song will have to
be reloaded.
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Learning a song
FM Organ has a feature that helps you learn any of the songs provided.
It teaches you how to play a song by highlighting the alphabetical keys
corresponding to the music notes on the keyboard. With such a feature, all
you need to do is to press the key every time it is highlighted.
To learn a song:
1

Press <F6> from the main menu.

2

Choose the song you want to learn using <Page Up>, <Page Down>, or the arrow keys.

3

Press <F8,F1>.

A layout of the PC keyboard similar to Figure 4-4 appears.

Figure 4-4 Layout of the PC keyboard for learning songs.
4

Press <F1> for a demonstration on how the song is played using the PC keyboard.

5

Press <F2> for a step-by-step lesson on how to play the song.

When <F2> is pressed, a numeric key will be highlighted in brown. This
signals you to get ready to press the key. When the alphabetical key below the
numeric key is highlighted in magenta, it means you must press the key. If the
key is not pressed, FM Organ will wait for you to press the key before
proceeding to the next one.

FM Intelligent Organ
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Playing FM Organ
To play FM Organ, press <F2> from the main menu. When you press any of
the keys on the PC keyboard, you should hear a corresponding sound. If you
cannot hear any sound, please check the settings in the Sound control panel
(in the Mac OS).
If you are not able to find something to play, you can try the tunes in Figures
4-5 and 4-6. To play the tunes, press the keys on the PC keyboard that
correspond to the number on the music notes. For example, the first seven
notes in Figure 4-5 are as follows: 1 1 5 5 6 6 5.
You can use any of the four octaves, that is, any of the four rows on the PC
keyboard to play the tune.
If you choose row 1, type: 1 1 5 5 6 6 5
If you choose row Q, type: Q Q T T Y Y T
To quit from playing FM Organ, press <Esc>.

Figure 4-5 Music score for “Twinkle, Twinkle, Little Star.”
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Figure 4-6 Music score for “When the Saints Go Marching In.”

Saving, loading, and replaying a song
To save a song you have played using FM organ:
1

Return to the main menu, then press <F7>.

2

Enter the name of the song when prompted.

3

Press <Enter>.

FM Organ remembers the song you have played by storing it temporarily in a
reserved memory area in your computer called the buffer. The buffer is 64
KB. Under normal conditions, the words “Buffer Status” will be indicated in
blue. When the buffer is almost full, the words will become red. If you want
to play the song again before saving it, press <F4>. After that, press <F7> if
you want to save it, or <Esc> to quit.

FM Intelligent Organ
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To make sure the song has been saved, press <F2,Esc>. By so doing, you are
removing the song stored in the buffer. With the song removed from the
buffer, you can check whether the song has been saved when you press
<F6,Enter> to load the song. If the song is not found, it means that it has not
been saved.
To replay the song, press <F3> or <F4>. For <F3>, the song will only play
once. But for <F4>, the song will keep on repeating until <Esc> is pressed.
Changes made to the song while in the <F4> mode will not be saved.
However, in the <F3> mode, the changes can be saved by pressing <F7>.

Adding accompaniment to songs
FM Organ comes with several features that will not only enhance the song
you play, but also make you seem like a virtuoso. These features are Auto
Bass-Chord, Auto Arpeggio, and Artificial Melody.

Auto Bass-Chord
The Auto Bass-Chord adds bass and chord to a song when <Spacebar> is
pressed. To stop Auto Bass-Chord, press <Spacebar> again. To ensure Auto
Bass-Chord does not end abruptly when you want to end this feature, press
<Enter> instead of <Spacebar>. To increase/decrease the volume for Auto
Bass-Chord, use <Page Up>/<Page Down> or the arrow keys on the numeric
keypad.

Auto Arpeggio
The Auto Arpeggio adds a melodious touch to a song by playing the chord
not simultaneously but in rapid succession. To select any of the six arpeggios,
use the right or left square bracket. To stop Auto Arpeggio, press < ‘ >. To
increase/decrease the volume for Auto Arpeggio, use the up/down arrow key
on the numeric keypad.

Artificial Melody
When the Artificial Melody is activated, you will hear a string of melody
accompanying what you are playing. This feature can be activated by pressing
<9>, <0>, <->, or <=>. To increase/decrease the volume for Artificial
Melody, use the <Home>/<End> key on the numeric keypad.
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Changing instruments and rhythms
All the songs in FM Organ consist of an instrument and a rhythm
accompanying it. Both the instruments and rhythms can be changed. The
instruments are represented by <F1> to <F4>. Each function key supports
five instruments, giving a total of 20 instruments. The rhythms are
represented by <F5> to <F8>. Each function key supports four rhythms,
giving a total of 20 rhythms. Pressing a function key lets you switch between
the various options (see Table 4-1).
To change the instruments and rhythms of a song:
1

Press <F2>.

The CMS’s Intelligent Organ control panel appears.
2

Select <F1> to <F4> for changing the instruments.

3

Select <F5> to <F8> for changing the rhythms.

4

To change the tempo of the rhythm, press <Ins> to increase it and <Del> to decrease it.
(The tempo is indicated by the “moving numbers” on the far-left.)

5

To change the scale of the songs, press <F9> for songs that are in major scale and
<F10> for songs that are in minor scale.

6

To transpose a song, press <+> to transpose the song one semitone up and <-> one
semitone down. Pressing <Shift + +> transposes a song four perfect tones up and
<Shift + -> transposes a song five perfect tones down.

Note: Changes made in CMS’s Intelligent Organ control panel cannot be
saved. To save the changes, you need to change the default settings.

FM Intelligent Organ
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F1

F2

F3

F4

Piano

Trumpet

Flute

Sitar

Harp

Saxophone

Harmonica

Jamaican

El guitar

Trombone

Clarinet

Bells

Marimba

Mars

Violin

Synth1

Alien

Organ1

Oboe

Synbass

F5

F6

F7

F8

March

Rhumba

Swing

Waltz

March1

Samba1

Swing1

Waltz1

March2

Bosonov1

Rock & Roll

Waltz2

March68

Tango1

Disco1

Jwaltz

Table 4-1 Instruments and accompaniment.

Changing default settings
To change the default settings of a particular song:
1

Press <F5> from the main menu.

The Default Settings window appears.
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2

Enter T to select the title of the song.

3

Use the up or down arrow key or press the characters highlighted in red to select the
options.

4

Use the right or left arrow key to change the default options.

5

Press <Enter> once you have confirmed the settings.

6

Press <F7> to save it or <Esc> to quit without saving.

7

Press <O> to restore the values to the factory default settings.

5

Windows Mixer

This chapter includes:
m Running Windows Mixer Control
m Controlling Options Using the Mouse or Keyboard
m The Windows Mixer Control Menus
Mixer Control is a powerful Windows audio mixer that allows you to
combine and manipulate sound from various audio sources. With this
windows mixer, it is possible to control the volume, tone, and gain of an audio
source while running other Windows applications.
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Running Windows Mixer Control
To run Windows Mixer:
m Expand the Mixer icon from your audio card’s group window.

The Mixer Control window similar to Figure 5-1 appears.

Figure 5-1 The Mixer Control window.

Controlling options using the mouse or keyboard
You can use the mouse or the keyboard to control the options in Mixer
Control.
When using the mouse to control an option:
m Click the option if it is in a check box.
m Move the slider button by dragging it or by clicking above or below the
slider to increase or decrease the volume/tone.
When using the keyboard to control an option:
m Use <Tab> to move to the option.
m Use the up or down arrow key to increase or decrease the volume/tone.
m Press <Shift+Tab> to move through the options backwards.
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Mixer Control menus
The windows mixer has two menus: Options and Help.

The Options menu
The description of the command on the Options menu is as follows:
Command

Description

Lock L/R Vol

Locks both the right and left channels of the sources so that both channels
move at the same time when you drag the slider button to the desired
volume level.

The Help menu
The description of the command on the Help menu is as follows:
Command

Description

About Mixer Control

States copyright information of the application.

Windows Mixer
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Creative WaveStudio

This chapter includes information on the following WaveStudio features:
m Running WaveStudio
m The WaveStudio Interface
m The WaveStudio Menus
m Opening Waveform Files
m Inserting Waveform Files
m Modifying Waveform Files
m Quitting WaveStudio
Creative WaveStudio is a powerful application for playback and editing of
both 8- and 16-bit waveforms within the Windows environment. It supports
the Windows Multiple Document Interface (MDI), which allows you to work
with several waveform files within a single application.

29

Running WaveStudio
WaveStudio can edit and play Microsoft waveform files. These files are
accompanied by the WAV extension.
To run WaveStudio window:
m Double-click the WaveStudio icon in the audio card’s group window.
The WaveStudio window similar to Figure 6-1 appears.

Figure 6-1 The WaveStudio window.

30

Chapter 6

The WaveStudio interface
The WaveStudio interface has four main features. They are the Toolbar, Edit
Window, Preview Window, and Status Bar.

Toolbar
The Toolbar comprises several buttons for file operations and control boxes
for waveform operations.

The buttons on the Toolbar are:
Opens a new window in WaveStudio containing no waveform data.

Opens an existing waveform file.

Saves the open waveform file to disk.

Cuts a portion of the waveform file.

Duplicates a portion of the waveform file.

Copies a portion of the waveform file to the Windows Clipboard.

Plays the waveform file that is currently in WaveStudio.

Stops playing a waveform file.

Pauses/resumes playing a waveform file.

Activates the Windows Mixer.

Creative WaveStudio
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The control boxes on the Button Bar are:
Displays the starting position of a selected portion
of a waveform. You can type the position in the text box
or use the scroll arrows to move to the starting position.
Displays the size of a selected portion of a waveform.
You can type the size in the text box or use the scroll arrows
to increase/decease the size.
Displays the zoom ratio of a waveform file. You can type
the ratio in the text box or use the scroll arrows to increase/decrease
the ratio.

Edit Window
The Edit Window is the area where the contents of waveform files are
displayed. This is the area where you may select and edit part or all of the
waveform.
To have a better view of a portion of the waveform, use the scroll bar at the
bottom of the Edit Window to move the waveform to that portion and use the
scroll arrows in the Zoom box to increase the size of that portion.
To select a portion of the waveform for editing, hold down the left mouse
button anywhere on the Edit Window and drag the mouse. Once the desired
portion of the waveform has been selected, release the left mouse button. The
selected areas will be highlighted. If you wish to edit the entire waveform,
double-click the Edit Window.
Note: When you click the right mouse button on the Edit Window, a menu of
commands allowing you to perform various functions will be displayed.
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Preview Window
The Preview Window displays the entire waveform currently loaded for
editing. You can also select a portion of the waveform for editing by clicking
anywhere on the Preview Window with the left mouse button and dragging
the mouse. The area selected will be highlighted. If you wish to select the
entire waveform, double-click on its window.
Within the Preview Window is the Progress Indicator that shows the progress
of a waveform that is being played. If the entire waveform is selected, the
Progress Indicator moves from the start to the end of the waveform. If a
portion of a waveform is selected, the Progress Indicator moves through the
waveform from the start to the end of the selected portion of the waveform.

Status Bar
The Status Bar displays information about each menu command when
selected with the mouse. It also provides information related to the waveform
in the Edit Window.

Note: A window has to contain waveform data before the information
relevant to the waveform is displayed in the Status Bar.
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The WaveStudio menus
WaveStudio has seven menus: File, Edit, View, Special, Options, Window,
and Help.

The File menu
The File menu lists all the file commands. The descriptions of these
commands are:
Command

Description

New

Creates a new window without any waveform data.

Open

Opens either an existing file that contains raw sound data or opens a file in
the WAV file format.

Close

Closes an opened waveform file.

Close All

Closes all opened files.

Save

Saves changes made to the waveform file.

Save As

Saves the waveform file with a new name.

Save All

Saves all open files.

Exit

Quits WaveStudio.

Note: WaveStudio keeps a record of the four latest waveform files you have
opened by displaying them after the Exit command. To open any of the files,
select the file with the left mouse button.
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The Edit menu
The Edit menu contains all the basic editing commands. The descriptions of
these commands are:
Command

Description

Undo

Undoes the last action performed.

Cut

Removes a selected portion of the waveform into an internal buffer.

Copy

Copies a selected portion of the waveform into an internal buffer.

Paste

Pastes the contents of the internal buffer into the Edit Window. If you have
selected a portion of the waveform, that portion is replaced by the contents
of the buffer. Otherwise, WaveStudio pastes the contents of the buffer at
the cursor.

Paste Mix

Mixes the contents of the internal buffer with the waveform in the Edit
Window.

Delete

Deletes a selected portion of the waveform. Unlike the Cut command, the
waveform is not placed in the internal buffer.

Crop to Selection

Deletes the entire waveform except the selected portion.

Select All

Selects the entire contents of the waveform in the Edit Window. You can
also do this by double-clicking the mouse anywhere in the Edit Window.

The View menu
The commands on the View menu allow you to customize the WaveStudio
workspace. The descriptions of these commands are:
Command

Description

Preview

Toggles the Preview Window between on and off.

Toolbar

Toggles the Toolbar between on and off.

Status Bar

Toggles the Status Bar between on and off.

Fit Wave In Window

Scales (adjusts the zoom ratio) the waveform to fit the size of the window.

Actual Size

Resets the zoom ratio of the waveform in the Edit Window to 1:1.

Cursor Position

Brings initial cursor position into view.

Cursor End

Brings cursor end position into view.

Zoom

Zooms a selected area to fit the size of the window.
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The Special menu
The commands on the Special menu allow you to add special effects to a
waveform. The descriptions of these commands are:
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Command

Description

Reverse

Reverses the playback of the entire waveform.

Add Echo

Adds echo effect to a certain portion of the waveform or an entire
waveform.

Invert Waveform

Inverts the wave data for the selected channel(s).

Rap!

Repeats a selected portion of the waveform.

Insert Silence

Inserts silence into a selected portion of the waveform. This command is
used when you want to add a pause between the sounds in a waveform.

Force to Silence

Silences a selected portion of the waveform. For stereo waveforms, there
are options for silencing either channel.

Fade In

Fades into a selected portion of the waveform.

Fade Out

Fades out of a selected portion of the waveform.

Swap Channels

Swaps Left and Right Channels.

Pan Left to Right

Pans waveform from Left to Right Channel.

Pan Right to Left

Pans waveform from Right to Left Channel.

Phase Shift

Applies phase shift to the selected channel.

Convert Format

Converts waveform channels (stereo or mono), sampling rate frequence,
and sampling size (8 or 16 bit).

Modify Frequencies

Modifies the playback rate of the wave.

Amplify Volume

Changes the volume level of a waveform. If the waveform is not selected,
this command will amplify the entire waveform. Otherwise, only the
selected portion will be amplified.

The Options Menu
Command

Description

Mixer Settings

Opens the Mixer Control Window.

Customize Colors

Customizes WaveStudio’s display colors for the Edit and Preview
windows.

Display in Bytes

Displays waveform in bytes.

Display in Samples

Displays waveform in samples.

Display in Milliseconds Displays waveform in milliseconds.
Always on Top

Toggles WaveStudio as the topmost window.

The Window menu
The commands on the Window menu specify several ways of organizing
windows when running WaveStudio. For more information regarding these
commands, refer to the manual on Microsoft Windows.

The Help menu
The descriptions of the commands on the Help menu are:
Command

Description

Contents

Displays contents for WaveStudio Help.

Search for Help on

Searches for a topic in WaveStudio Help.

System Info

Displays information about Windows and your system.

About WaveStudio

Displays copyright information of the application.
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Opening waveform files
To open an existing waveform file:
1

Choose Open from the File menu.

The Open Sound File dialog box similar to Figure 6-2 appears.

Figure 6-2 The Open Sound File dialog box.
2

Select the file you wish to open from the File Name list box.

3

Choose OK.

Inserting waveform files
A waveform file can be inserted into WaveStudio by dragging and dropping.
To do this:
1

Start File Manager and open the directory containing the waveform file you want to drag.

2

Select the desired waveform file.

3

Arrange your windows so that both the waveform file and the WaveStudio Window can
be seen.

4

Drag the waveform file by holding down the left mouse button while pulling the file
into Edit Window. A plus sign in the icon will be seen as you drag the file into the
WaveStudio Window.

5

Release the mouse button when the icon is in the WaveStudio Window.

WaveStudio will automatically open the file for editing. To select multiple
files from the File Manager, hold down <Shift> and click on the mouse
button, and drop them into the WaveStudio Window. WaveStudio will
automatically open all the files for you.
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Modifying waveform files
You can change the shape and characteristics of a waveform by using the
commands from the Edit and Special menus.
To mix the contents of the internal buffer with the waveform in the Edit
window:
1

Select Paste Mix from the Edit menu.

The Paste Mix dialog box similar to Figure 6-3 appears.

Figure 6-3: The Paste Mix dialog box.
2

Select a channel for the internal buffer and the waveform.

For stereo waveforms, the following are the options available for mixing:
m the corresponding master channel
m left (buffer) to left (waveform) channel
m right (buffer) to right (waveform) channel
m left (buffer) to right (waveform) channel
m right (buffer) to left (waveform) channel
Note: For master to master channel mixing, the left (buffer) goes to the left
(waveform) channel, and the right (buffer) goes to the right (waveform)
channel.
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3

Choose OK.

As a result of this mixing process, the contents of the buffer are added to the
waveform. When you play back the waveform, you will hear both sounds
together. If no portion of the waveform is selected, the buffer contents are
placed at the cursor. If a portion of the waveform is selected, the contents of
the buffer and the waveform data are mixed.
To add echo to a selected portion of a waveform:
1

Select Add Echo from the Special menu.

The Add Echo dialog box similar to Figure 6-4 appears.

Figure 6-4 The Add Echo dialog box.
2

Enter the echo magnitude in the Magnitude text box.

Echo magnitude (i.e. how loud the echo sounds) should be in percentage.
3

Enter the echo delay in the Echo Delay text box.

Echo delay (i.e. the time between the actual sound and the echo) should be in
milliseconds.
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4

Select the Channel in which you wish to add the echo.

5

Choose OK.

To add silence to a selected portion of a waveform:
1

Choose Force to Silence from the Special menu.

The Force to Silence dialog box similar to Figure 6-5 appears.

Figure 6-5 The Force to Silence dialog box.
2

Choose the channel or channels to silence out.

The channels available are the master, and the left and right channels of the
stereo waveform.
3

Choose OK.

To fade in/out a selected portion of a waveform:
1

Choose either Fade In or Fade Out from the Special menu.

If Fade In is selected, the Fade In dialog box similar to Figure 6-6 appears. If
Fade Out is selected, a similar dialog box to Figure 6-6 will appear with Fade
Out as the title.

Figure 6-6 The Fade In dialog box.
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2

Enter the starting magnitude in the Magnitude text box if Fade In is selected. Enter the
ending magnitude on the Magnitude text box if Fade Out is selected.

3

Choose the channel you wish to perform the fade in or fade out. (For stereo waveforms,
there are additional options for fading both channels or only one channel.)

4

Choose OK.

To amplify the volume of a selected portion of a waveform:
1

Choose Amplify Volume from the Special menu.

The Amplify Volume dialog box similar to Figure 6-7 appears.

Figure 6-7 The Amplify Volume dialog box.
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2

Enter the magnitude of the volume in percentage.

3

Choose the channel you wish to amplify the volume. (For stereo waveforms, there are
additional options for amplifying both channels or only one channel.)

4

Choose OK.

Quitting WaveStudio
To quit WaveStudio:
1

Choose Exit from the File menu.

If you made changes and have not saved them, the Creative WaveStudio dialog
box similar to Figure 6-8 will appear.

Figure 6-8 Creative WaveStudio dialog box.
2

Choose Yes to save the changes, No if you do not want to save the changes, or Cancel if
you want to continue working in WaveStudio. (By selecting Yes or No you will
immediately exit WaveStudio.)
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Appendix
New Files on Your Hard Disk

Read this appendix for a list of all Sound Blaster files installed on your
hard disk.
m In the \SB16 directory, you will find the following:
FILELIST.LST List of all Sound Blaster-related files on your hard disk.
README.COM Program to display the README.TXT file.
README.TXT Text file containing latest information not in the manual at

print time.
CQA.COM Program to display the CQA.TXT file.
CQA.TXT Text file for commonly asked questions and the answers to them.
MIXERSET.EXE Mixer controller.
CTMIX.CFG Configuration file for MIXERSET.EXE.
WINSETUP.EXE Audio software’s Windows 3.1 applications set up program.
WINSETUP.INF WINSETUP program information file.
INSTALL.EXE Audio software installation program.
INSTALL.PVL Compressed library for INSTALL.EXE.
SBMIDI.EXE MIDI driver.
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m In the \SB16\DRV sub-directory, you’ll find the following files:
AUXDRV.DRV Auxiliary driver for controlling volume.
CT-VOICE.DRV Loadable driver for voice (memory version).
CTVDSK.DRV Loadable driver for voice (disk version).
CTWDSK.DRV Loadable driver for wave (disk version).
CTWMEM.DRV Loadable driver for wave (memory version).
ORGAN.DRV Driver for PRO_ORG.

m The following files are located in the \SB16\PLAYMIDI sub-directory:
PLAYMIDI.EXE MIDI file player.
*.MID Sample MIDI files.

m The \SB16\VOCUTIL sub-directory includes the following:
VOC2WAV.EXE Voice file to Wave file converter.
VOCHDR.EXE Program to add a header to raw voice files.

VOCN2O.EXE Program to convert new voice files to old format.
VOCO2N.EXE Program to convert old voice files to new format.
VPLAY.EXE Program to play voice files.
WAV2VOC.EXE Wave file to voice file converter.
WPLAY.EXE Program to play a wave file.

m In the \SB16\SAMPLES sub-directory:
S_8_22.WAV Sample wave file.

m In the \SB16\WINAPPL sub-directory:
WMIXER16.EXE Mixer controller.
CTWAVE.EXE Audio software WaveStudio program.
CTWHELP.EXE Help for Audio software WaveStudio program.

46

Appendix

m The \SB16\PRO_ORG sub-directory contains:
PRO_ORG.EXE Intelligent Organ program.
*.ORG Sample organ files.

m The following files reside in the \SB16\WINDRV sub-directory:
VSBPD.386 Windows virtual device driver.
MIDIMAP.CFG Windows MIDI map configuration file.
SB16AUX.DRV Auxiliary driver.
SB16FM.DRV Voyetra / Sound Blaster SuperSAPI FM Driver.
SB16SND.DRV Wave and MIDI driver.
OEMSETUP.INF Windows set up file.
CSPMAN.DLL Advanced Signal Processor dynamic link library.
CTRES.DLL Audio hardware’s resources dynamic link library.
CTCCW.DLL Audio hardware’s custom controls for Windows dynamic

link library
CTL3D.DLL Windows 3D effect dynamic link library.
CTWFLT.DLL Audio hardware’s Wave filter manager.
WFLT0001.DLL Wave filter for PCM format.
WFLT0002.DLL Wave filter for MS ADPCM format.
WFLT0006.DLL Wave filter for CCITT A-Law format.
WFLT0007.DLL Wave filter for CCITT u-Law format.
WFLT0011.DLL Wave filter for IMA/DVI ADPCM format.
WFLT0200.DLL Wave filter for Creative ADPCM format.
WFM0006.ACV Windows driver for software CODEC for CCITT A-Law
WFM0007.ACV Windows driver for software CODEC for CCITT u-Law.
WFM0011.ACV Windows driver for software CODEC for IMA/DVI ADPCM.
WFM0200.ACV Windows driver for software CODEC for Creative ADPCM

New Files on Your Hard Disk
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The following files will be copied to your Windows or Windows \SYSTEM
directory. You should not have duplicate copies of these files in both
directories.
The following files should reside in your WINDOWS directory:
CTRES.DLL

CTCCW.DLL

The following files should reside in your WINDOWS\SYSTEM directory:
VSBPD.386
MIDIMAP.CFG
WFM0200.ACV
WFLT0001.DLL
WFLT0011.DLL
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SB16SND.DRV
CSPMAN.DLL
WFM0011.ACV
WFLT0002.DLL
WFLT0200.DLL

SB16FM.DRV
WFM0006.ACV
CTL3D.DLL
WFLT0006.DLL

SB16AUX.DRV
WFM0007.ACV
CTWFLT.DLL
WFLT0007.DLL
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