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PhotoFlash allows you to organize photographs and other digitized images,
enhance them, and place them in a document created with another
application program. To start using PhotoFlash, follow the instructions in
PhotoFlash Getting Started. That guide describes how to install the PhotoFlash
software and start using it within just a few minutes. 

This guide is a reference to everything you need to know about using
PhotoFlash. After you’ve read PhotoFlash Getting Started, you should be able
to start using PhotoFlash with your own images right away. If you have
questions about any of PhotoFlash’s capabilities while you’re working, you
can look up the task you want to learn about in this guide.

What you need to know

This guide assumes that you have installed the PhotoFlash software according
to the directions in PhotoFlash Getting Started and that you understand how to
perform the other tasks described in that guide. It also assumes that you’re
familiar with the basics of using Macintosh System 7: how to work with disks,
programs, folders, and files and how to use menus and dialog boxes. For more
information on Macintosh basics, see the Macintosh User’s Guide provided
with your computer.

ix
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How to use this book

This guide is organized according to tasks. Use the Contents or the Index to
locate instructions for specific tasks.

Descriptions of tasks in this guide often include numbered steps. Each step
consists of a short instruction in boldface type followed (usually) by further
explanation in plain type. Depending on your level of expertise with
PhotoFlash and other Macintosh programs, you may find that you can speed
through some or all of the instructions by reading just the boldface steps and
looking at the pictures:

1 The boldface steps like this tell you what to do.

The text like this gives you extra help.

2 Pictures like this show you what to look for on your computer screen:

This guide contains the following chapters and appendixes:

m Chapter 1, “Using Catalogs,” describes how to create and use PhotoFlash
catalogs—collections of thumbnails that represent image files stored
anywhere on your hard disk or on other volumes, including other volumes
on a network.

m Chapter 2, “Working With Image Files,” describes how to open, view, and
save image files with PhotoFlash. This chapter also describes the standard
image file formats that PhotoFlash supports.

m Chapter 3, “Working With Selections,” describes how to use the Selection
tools in the PhotoFlash Tool palette to select part of an image. After you’ve
selected an area, you can use the Action tools to manipulate or enhance it
as described in Chapters 4 and 5.

m Chapter 4, “Manipulating Images,” describes how to use commands in the
Image menu to crop, resize, straighten, rotate, flip, and change the number
of colors used by an image. It also describes how to manipulate selections
by using the Crop, Resize, and Rotate tools in the PhotoFlash Tool palette.
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m Chapter 5, “Enhancing Images,” describes how to use commands in the
Enhance menu to adjust an image’s red, green, and blue (RGB) values,
balance an image’s exposure, blur or sharpen an image, and remove dust
and scratches. It also describes how to enhance selections by using the
Blur, Sharpen, DeDust, and DeScratch tools in the PhotoFlash Tool palette.

m Chapter 6, “Converting and Compressing Files,” describes how to convert
image files from one format to another. It also discusses the five standard
file formats supported by PhotoFlash and describes how to use JPEG
compression, which is a standard format for image compression that can be
used with most file formats.

m Chapter 7, “Automating Your Work,” describes how to record and run
scripts that perform repetitive tasks in PhotoFlash and other programs.

m Appendix A, “Setting PhotoFlash Preferences,” describes how to use
controls and settings in the Preferences dialog box (available from the Edit
menu) to control various aspects of the way PhotoFlash works.

m Appendix B, “Using Photoshop-Compatible Plug-In Modules,” describes
how to use PhotoFlash with third-party plug-in modules designed for use
with Photoshop.

m Appendix C, “PhotoFlash Acceleration,” describes PhotoFlash’s support for
program-specific accelerator cards designed to work with application
programs such as PhotoFlash, Adobe™ Photoshop (versions 2.0.1, 2.5, or
higher), and PicturePress.

You can find definitions of unfamiliar terms in the Glossary. Use the Index to
find instructions for specific tasks or information about specialized topics and
commands.
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PhotoFlash allows you to create collections of images called catalogs. You can
use catalogs to organize images that you want to group together. For example,
you could create a catalog that represents all the images you want to use in
one issue of a newsletter, or all your photos from a vacation, or all the images
for a chapter of a book. You can also manipulate multiple images at the same
time from within a catalog.

A catalog is a PhotoFlash document that you can save and open like other
documents. When you open a catalog, you see a series of thumbnails, or small
reproductions of the images that it represents. You can arrange a catalog’s
thumbnails in any order you like; add to or remove them; or search for
specific images by name, by caption text, or by their resemblance to other
images or a rough sketch.

A catalog doesn’t contain the actual image files that correspond to each
thumbnail. Instead, it contains a small copy (the thumbnail) of each file
and keeps track of the file’s location. The arrangement of thumbnails in a
catalog is completely independent of the arrangement of the image files on
your hard disk.

1
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Creating a catalog

You can create a new catalog from within PhotoFlash or from the desktop.

Creating a catalog from within PhotoFlash

To create a new catalog from within PhotoFlash, follow these steps:

1 Choose New from the File menu.

The New dialog box appears.

2 If it’s not already selected, click Catalog to indicate that you want to create a new
catalog.

When the Catalog button is selected, the Image Setup information in the
dialog box is dimmed.

3 Click OK.

A new, empty catalog document appears. To add images to your new catalog,
follow the directions in “Adding Image Files to a Catalog” later in this
chapter.

Creating a catalog from the desktop

If some of the image files you want to include in a catalog are located within
a folder on the desktop, follow these steps:

1 Locate the PhotoFlash program’s icon on the desktop.
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Unless you have moved it since installing PhotoFlash, the PhotoFlash
program should be located in the PhotoFlash folder.

2 Locate the folder that contains the images you want to include in a new catalog.

3 Drag the folder icon over the PhotoFlash icon and release the mouse button.

When the folder you are dragging is directly over the PhotoFlash icon, the
icon becomes highlighted. (If it doesn’t become highlighted, you may need to
rebuild your desktop. To do so, hold down the x and Option keys and restart
your computer.)

After you release the mouse button, PhotoFlash opens a new catalog and
creates thumbnails in the catalog for all the image files in the folder. Like
most new Macintosh documents, the new catalog isn’t saved on your hard disk
until you choose Save As from the File menu and choose a name and location
for the catalog file.

If you drag several folder icons over the PhotoFlash icon at once, the catalog
will include all the images in all the folders. If you drag individual images
over the PhotoFlash icon, PhotoFlash opens the images instead of creating a
catalog for them.
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PhotoFlash creates a new catalog each time you drag icons for folders or disks
that contain image files over its icon. If you want to add images to a catalog
that already exists, follow the directions in “Adding Image Files to a Catalog”
later in this chapter.

Saving a catalog

To save a new catalog, follow these steps:

1 Make sure the catalog you want to save is in the frontmost window.

2 Choose Save As from the File menu.

The Save As dialog box appears.

3 Use the dialog box to give the catalog file a name and select a location for it.

4 Click Save.

As with most other Macintosh documents, after you’ve saved a catalog for the
first time you can continue working on it and save it again at any time by
choosing Save from the File menu.
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Opening and closing a catalog

You can open a previously saved catalog from within PhotoFlash or from
the desktop.

Opening a catalog from within PhotoFlash

To open a catalog file from within PhotoFlash, follow these steps:

1 Choose Open from the File menu.

The Open dialog box appears.

2 Use the Open dialog box to locate the catalog file you want to open.

When you select a catalog file, the catalog icon appears in the lower-right
corner of the dialog box, as shown in the figure. When you select an image
file, the image’s thumbnail (if one is available) appears instead.

3 Click Open.

PhotoFlash opens the catalog and, if necessary, updates its thumbnails.
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Opening a catalog from the desktop

To open a catalog file from the desktop, double-click its icon.

Closing a catalog

To close a catalog, click its close box (in the upper-left corner of its window)
or choose Close from the file menu while the catalog’s window is the
frontmost window. If you haven’t saved the catalog or if you’ve changed it
since the last time you saved, a dialog box appears asking whether you want
to save your changes.

If the catalog you are closing includes thumbnails for images that are
currently open in PhotoFlash, and if any of those images or their captions
have been changed and haven’t yet been saved, PhotoFlash displays a dialog
box asking whether you want to save the images before closing the catalog.

Duplicating a catalog

To duplicate a catalog, make sure it’s in the frontmost window and choose
Duplicate Catalog from the File menu.

An exact duplicate of the catalog appears in a new untitled window.

Adding image files to a catalog

To add one or more image files to a catalog, you can drag their icons from the
Finder desktop into a catalog window or use the Add to Catalog command.
This section describes both methods.

If one open catalog includes thumbnails for the image files you want to add to
another open catalog, you can copy and paste the thumbnails or drag them
between the catalog windows. See “Moving and Copying Thumbnails” later
in this chapter for details.
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Dragging image file icons from the desktop to an open catalog

To drag icons for image files or folders that contain image files from the
desktop to an open catalog, follow these steps:

1 Make sure both the catalog window and the icons for the files you want to add are
visible.

2 Select the icons for the image files or folders.

3 Drag the selected icons from the desktop into the the catalog window.

Using the Add to Catalog command

To add image files to a catalog from within PhotoFlash, follow these steps:

1 Make sure the catalog to which you want to add images is the frontmost window. 

2 Choose Add to Catalog from the File menu. 
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The Add to Catalog dialog box appears.

3 Use the Add to Catalog dialog box to locate and select the first image file or folder of
image files that you want to add.

4 Click Add.

The selected file disappears from the list of files and folders. The text at 
the bottom of the dialog box indicates how many folders and files you have
selected so far. If you wish, you can add other image files or folders. Only
image files (whether selected individually or within a folder) will show up in
the catalog.

5 When you have finished adding image files to the catalog, click Done. 

After a few moments, thumbnails for the image file or files you selected
appear in the catalog. If you change your mind about including any of the
images, select the ones you don’t want and press the Backspace or Delete key.
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Resizing catalog windows

You can resize a catalog window the same way you resize any Macintosh
window, by dragging the resize box in its lower-right corner. When you do so,
the overall ordering of the thumbnails from the beginning to the end of the
catalog remains the same, but PhotoFlash rearranges them so the width of
each row fits in the window.

You can also use a catalog window’s Zoom box to toggle between window
sizes.

To toggle a window’s size between its current dimensions and the maximum
dimensions required to show as many thumbnails as possible, follow these
steps:

1 Click the catalog window’s Zoom box (in its upper-right corner). 

The window’s width increases as much as necessary to accommodate its
thumbnails, and its height changes so that either all the thumbnails are 
visible or, if all the thumbnails won’t fit on the screen, until the window fills
the screen.

2 To return the catalog window to its original size, click the Zoom box again.

To toggle a window’s size between its current height and the maximum height
required to show as many thumbnails as possible, without changing the
number of thumbnails in a row, follow these steps: 

1 Hold down the Option key and click the catalog window’s Zoom box (in the window’s
upper-right corner).

If any blank space is visible toward the right side of the window, the window’s
width decreases to eliminate the space, and the window’s height increases
until either all the thumbnails are visible or, if all the thumbnails won’t fit in
the window, until the height of the window matches the height of the screen.

2 To return the catalog window to its original size, click the Zoom box again. 
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Working with thumbnails

You can arrange thumbnails in a catalog however you wish. This section
describes how to select thumbnails, how to move them within or between
catalogs, how to sort them within a single catalog, and how to open the
images they represent.

You can manipulate one or more images from within a catalog by selecting
their thumbnails and choosing commands in the Image, Enhance, or Script
menus. For information about applying specific commands to thumbnails, see
Chapter 4, “Manipulating Images,” Chapter 5, “Enhancing Images,” and
Chapter 7, “Automating Your Work.”

If you change an image represented by a thumbnail in an open catalog, the
label “Changed” appears across the thumbnail to indicate that the catalog
thumbnail hasn’t yet been updated. PhotoFlash updates the thumbnail the
next time you open the catalog.

Selecting thumbnails

To select a single thumbnail, just click it. The area around the thumbnail’s
image becomes highlighted when the thumbnail is selected.

Selecting separate thumbnails

To select several thumbnails in different parts of the catalog, follow
these steps:

1 Click the first thumbnail you want to select.
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2 Hold down the Shift key (or the x key) and click the other thumbnails you want to select.

While you’re holding down the Shift key, each unselected new thumbnail
you click becomes selected, and previously selected thumbnails remain
selected. (Each selected thumbnail you click becomes unselected.) Only
thumbnails you click are added to the selection, even if they are separated by
other thumbnails.

Holding down the x key has the same effect as holding down the Shift key
when you’re selecting thumbnails.

Selecting a range of thumbnails

To select a continuous range of thumbnails, follow these steps:

1 Click the thumbnail at one end of the range of thumbnails you want to select.

2 Hold down the Option key and click the thumbnail at the other end of the range you want
to select.
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After you’ve selected one or more thumbnails, you can move them to any
location in the same catalog or in a different catalog. The next two sections
describe how.

Moving and copying thumbnails

You can move thumbnails within a catalog by selecting and dragging them.
When you drag thumbnails between catalogs, PhotoFlash inserts copies of the
thumbnails in the second catalog.

You can also move thumbnails between catalogs by cutting and pasting them.

Moving or copying thumbnails by dragging

You can drag selected thumbnails either within the same catalog or to a
different catalog. If you are copying thumbnails between catalogs, make sure
both catalog windows are open and visible on your screen.

To move or copy thumbnails by dragging them, first select the thumbnails
(see “Selecting Thumbnails” earlier in this chapter if you need instructions).
Then follow these steps:

1 Position the pointer over one of the selected thumbnails.

2 Drag the selected thumbnails to the location to which you want to move or copy them.

When you drag the pointer between two thumbnails, the vertical line between
them changes to red to indicate where the selected thumbnails will be
inserted if you release the mouse button.

If you drag the pointer slowly toward the right or bottom edge of a window
with active scroll bars, the window scrolls in the same direction.

3 When the pointer is over the location to which you want to move the selected
thumbnails, release the mouse button.

If the new location is in the same catalog, PhotoFlash moves the thumbnails
to their new location in the order you selected them and rearranges the other
thumbnails in the catalog as necessary. If the new location is in a different
catalog, PhotoFlash copies the thumbnails in the order you selected them and
rearranges the other thumbnails in the second catalog as necessary. The
thumbnails remain selected after you move them.
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Note: A catalog can contain only one thumbnail for each of its images. If you
attempt to drag several thumbnails to another catalog that already contains
some of the dragged thumbnails, PhotoFlash copies only those that are new.

Copying, cutting, and pasting thumbnails

When you copy or cut thumbnails and then paste them into a catalog,
PhotoFlash pastes them after any thumbnails that are currently in the catalog.
Therefore, pasting thumbnails within the same catalog isn’t useful unless you
want to move them to the end.

To move thumbnails between catalogs by cutting and pasting, first select the
thumbnails you want to move as described in “Selecting Thumbnails” earlier
in this chapter. Then follow these steps:

1 Choose Copy or Cut from the Edit menu.

2 Open the catalog you are moving the thumbnails to or activate its window.

3 Choose Paste from the Edit menu.

The thumbnails you copied appear, selected and in the order you selected
them, after the last thumbnail in the catalog.

Note: A catalog can contain only one thumbnail for each of its images. If you
attempt to paste thumbnails into a catalog that already contains some of the
same thumbnails, PhotoFlash pastes only those that are new

Sorting thumbnails

You can sort thumbnails in a catalog by filename or by date. Sorting occurs
only when you choose a PhotoFlash sort command from the Search menu.
You can change the thumbnail order any time you want by moving thumbnails
around as described in the previous section.

To sort a catalog’s thumbnails, follow these steps:

1 Make sure the catalog whose thumbnails you want to sort is in the frontmost window.

2 Choose Sort by Filename or Sort by Date from the Search menu.

PhotoFlash rearranges the catalog’s thumbnails by filename or by the date on
which each file was last modified. After sorting a catalog’s thumbnails, you
can rearrange them in any way you choose.
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Removing thumbnails from a catalog

To remove one or more thumbnails from a catalog, follow these steps:

1 Select the thumbnail or thumbnails you want to remove.

For detailed instructions, see “Selecting Thumbnails” earlier in this chapter.

2 Press the Backspace or Delete key or choose Clear from the Edit menu.

Or press the Clear key if your keyboard has one.

The thumbnails you selected disappear, and PhotoFlash rearranges the
remaining thumbnails as necessary.

Opening image files from a catalog

To open an image file from within a catalog that includes the image, just
double-click the image’s thumbnail.

To open several images from within a catalog, follow these steps:

1 Select the thumbnails for the images you want to open as described in “Selecting
Thumbnails” earlier in this chapter.

2 Double-click any of the selected thumbnails.

PhotoFlash opens the image files for all the selected thumbnails. If any of the
image files represented by selected thumbnails are on a disk or other volume
that isn’t visible on your desktop, PhotoFlash asks you to mount the volume.

Getting information about image files

You can view information about an image in a catalog, including its caption,
by opening its Get Info window.

To open the Get Info windows for one or more images from within a catalog,
follow these steps:

1 Select the thumbnail or thumbnails for which you want to view information.

For instructions, see “Selecting Thumbnails” earlier in this chapter.

14 Chapter  1



2 Choose Get Info from the File menu.

The Get Info window for the thumbnail you selected appears. If you selected
several thumbnails, a Get Info window appears for each of them. You can add
or edit caption text in this window. To locate the image file’s icon on the
desktop, click the Find Original button.

3 When you’re finished, click the Get Info window’s close box to close the window. 

You can also open the Get Info window for an image file that is currently
open in PhotoFlash. To do so, make sure the the image’s window is active and
choose Get Info from the file menu.

Printing a catalog

To print the thumbnails in a catalog in a form similar to a contact sheet for a
roll of film, follow these steps:

1 Make sure the catalog you want to print is in the frontmost window.

2 Choose Print from the File menu.
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The Print dialog box appears.

3 Adjust the settings in the Print dialog box.

4 Click OK.

PhotoFlash prints the catalog as you specified.

Searching for images

You can use commands in the Search menu to search for images in one
catalog or in all of your open catalogs by name, by caption text, or by
resemblance to other images or a rough sketch.

Searching for images by caption text

To search for images by caption text, make sure the catalogs you want to
search are open, then follow these steps:

1 Choose Caption Text from the Search menu.
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The Search Caption Text dialog box appears.

2 Type the text you want to find.

Capitalization and diacritical marks don’t matter. PhotoFlash looks for images
with captions that include the text you specify.

3 Select the search options you want. 

The default settings cause PhotoFlash to search only one catalog and to
highlight the selected images in that catalog.

4 Click OK or press Return.

When the search is complete, PhotoFlash selects the matching thumbnails in
their original catalogs or, if you selected the Put Results in New Catalog
checkbox, creates a new untitled catalog containing copies of all matching
thumbnails.
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Searching for images by filename

To search for images by filename, make sure the catalogs you want to search
are open, then follow these steps:

1 Choose Filenames from the Search menu.

The Search Filenames dialog box appears.

2 Type the filename or a portion of the filename you want to find.

Capitalization and diacritical marks don’t matter. PhotoFlash looks for images
with filenames that include the text you specify.

3 Select the search options you want. 

The default settings cause PhotoFlash to search only one catalog and to
highlight the selected images in that catalog.

4 Click OK or press Return.

When the search is complete, PhotoFlash selects the matching thumbnails
in their original catalogs or, if you selected the Put Results in New Catalog
checkbox, creates a new untitled catalog containing copies of all matching
thumbnails.
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Searching for images that resemble a sketch

You can use the Using Sketch command in the Search menu to draw a rough
sketch of an image and search for catalog images that resemble the sketch.
The Using Sketch command can identify general similarities based on color
and (to a lesser extent) shape, but may not always be able to locate an
individual image. However, it’s worth trying if you don’t know anything about
the image’s caption or filename. It’s also useful if you want to identify several
images with similar colors or compositions.

To search for images by their similarity to a sketch, make sure the catalogs
you want to search are open, then follow these steps:

1 Choose Using Sketch from the Search menu.

The Search Using Sketch dialog box appears.

2 Use the color palette and the Pencil and Eraser tools to create a sketch that resembles
the image you want to find.

If you click on any thumbnail while this dialog box is open, a sketch based on
that thumbnail appears in the sketch area. You can then use the Pencil tool to
add to the sketch and the Eraser tool to erase. To erase the whole sketch and
start over, double-click the Eraser tool.
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3 Select the search options you want. 

The default settings cause PhotoFlash to search only one catalog and to
highlight the selected images in that catalog. It’s usually a good idea to select
the Put Results in New Catalog option, because PhotoFlash sorts the
thumbnails in the new catalog in order of their similarity to the sketch.

4 Click OK or press Return.

When the search is complete, PhotoFlash selects the matching thumbnails in
their original catalogs or, if you selected the Put Results in New Catalog
checkbox, creates a new untitled catalog containing copies of all the matching
thumbnails, starting with those that most closely resemble the sketch on
which the search was based.

Searching for similar images

You can use the Similar Images command in the Search menu to search for
catalog images that resemble a specific image. The Similar Images command
can identify general similarities based on color, but may not always be able to
locate an individual image. However, it’s worth trying if you don’t know
anything about the image’s caption or filename. It’s also useful if you want to
identify several images with similar colors or compositions.
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For example, if you use the Similar Images command to look for pictures
similar to a picture of a beach, PhotoFlash will probably identify pictures of
beaches that contain similar colors. However, if you look for pictures similar
to a picture of a cat, PhotoFlash probably won’t identify other pictures of cats,
because the colors in pictures of cats vary a lot more than the colors in
pictures of beaches.

To search for images by their similarity to another image in a catalog, make
sure the catalogs you want to search are open, then follow these steps:

1 Select the thumbnail for an image that resembles the image you want to find.

You can’t search for similar images unless you have a single thumbnail
selected.

2 Choose For Similar Images from the Search menu.

The Search for Similar Images dialog box appears.

3 Select the search options you want.

The default settings cause PhotoFlash to search only one catalog and to
highlight the selected images in that catalog. It’s usually a good idea to select
the Put Results in New Catalog option, because PhotoFlash sorts the
thumbnails in the new catalog in order of their similarity to the sketch.
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4 Click OK or press Return.

When the search is complete, PhotoFlash selects the matching thumbnails or,
if you selected the Put Results in New Catalog checkbox, creates a new
untitled catalog containing copies of all the matching thumbnails, starting
with those that most closely resemble the image on which the search was
based. In the example shown here, the images that include blue sky or sea are
listed first.
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PhotoFlash allows you to work with image files in a variety of formats. This
chapter describes those formats and explains how to open, view, save, and
print image files.

Macintosh image files

Images are stored as files, just like other Macintosh documents. You can get
images from a variety of sources, including Photo CDs, digital cameras such
as Apple’s QuickTake camera, video frame-grabbing programs, scanners, and
online services and bulletin boards. They may be in black and white, shades
of gray, or color.

Image files come in several formats. PhotoFlash can interpret the most
commonly used formats, which means it can open most kinds of image files
you’re likely to run across. You can also use PhotoFlash to convert image files
from one format to another.

When a color image is stored as a Macintosh file, the file includes
information about the number of colors that appear in the image. In general,
the more colors an image file can use, the better the image looks on the
screen; but image files that use a lot of colors take up more room on disk than
files that are restricted to fewer colors. For more information about the use of
color in image files, see “Changing the Number of Colors Used by an Image”
in Chapter 4, “Manipulating Images.”
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Image files often include a caption and a thumbnail, which is a miniature
reproduction of the image. Thumbnails appear in catalog windows, in the
Open dialog box when you select an image file, and in the Get Info window
for an image.

File formats recognized by PhotoFlash

PhotoFlash can open image files saved in any of the following file formats:

m PICT is the standard Macintosh format for image files. PICT files can also
be opened in the Windows environment if QuickTime is installed in the
Windows system.

m TIFF (Tagged Image File Format) is a commonly used file format for both
Macintosh and MS-DOS system software. You can use a Macintosh
program to open a file saved in the TIFF format from an MS-DOS
program, and vice versa.

m EPS (Encapsulated PostScript™) is a format used primarily to export image
files for use with page layout programs. EPS files may include line art as
well as images. PhotoFlash can open EPS files that contain bitmapped
images like those created by Adobe Photoshop, but it can’t open EPS files
that contain nonbitmapped images, like those created in Illustrator, which
consist of mathematically defined shapes.

m JPEG (Joint Photographic Experts Group) is a standard method of
compressing image files. You can apply JPEG compression to files saved in
most of the formats that PhotoFlash supports, and you can save files in the
JPEG file format.

m DCS (Desktop Color Separation, version 1.0) is a variation of the EPS file
format used by page layout programs. It is also one form of CMYK file. An
image stored in the CMYK format used by DCS 1.0 is split into five separate
image files. Four of these files represent the color components of the
image: Cyan, Magenta, Yellow, and Black. The fifth is the Master file,
which shows how the whole image looks and can be viewed from within a
page layout program or from within PhotoFlash.
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m Photo CD is the file format used to save photographs on Kodak Photo CDs.
PhotoFlash can open Photo CD or Photo CD Pro files but can’t save files in
this format. For more information about this format, see “Opening a Photo
CD Image File” later in this chapter.

m Photoshop format is used by Adobe Photoshop. PhotoFlash can read data
from files saved with Adobe Photoshop 2.0 or 2.5, but can’t save files in this
format.

m Additional formats are supported by Photoshop-compatible plug-in
modules that you can obtain from other companies. Once installed,
these modules allow you to open, save, acquire, export, or apply
specialized enhancements to image files in a variety of formats from
within PhotoFlash. For more information about third-party plug-in
modules for PhotoFlash, see Appendix B.

For more information about the PICT, TIFF, EPS, JPEG, and DCS file
formats, see Chapter 6, “Converting and Compressing Files.”

Opening image files (non–Photo CD)

You can open one or more images that are part of a catalog at the same time
by selecting their thumbnails and then double-clicking one of the selected
thumbnails. For more information about working with thumbnails, see
Chapter 1, “Using Catalogs.”

You can also open any image file, whether it’s part of a catalog or not, by
using the Open command in the File menu. This section describes how to use
the Open command to open an image file in any format recognized by
PhotoFlash except for the Kodak Photo CD format. The next section
describes how to open Photo CD images.

To open an image file in any format other than Photo CD, follow these steps:

1 Choose Open from the File menu.
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The Open directory dialog box appears.

2 Use the directory dialog box to locate and select the image file you want to open.

3 Click Open or press Return.

PhotoFlash opens the file in a new window.

Opening a Photo CD image file

If you have a CD-ROM drive and a Photo CD disk, you can open the images
on the disc in PhotoFlash. Follow these steps:

1 Make sure your CD-ROM drive is turned on.

2 Choose Open from the File menu.

The Open dialog box appears (see figure in preceding section).

3 Insert the Photo CD disc.

The names of the folders on the Photo CD disc should appear in the directory
dialog box, including a folder named PHOTO_CD. If you can’t see this folder,
use the directory dialog box to locate and open the CD icon.
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4 Open the folder named PHOTO_CD, then open the folder inside it named IMAGES.

5 Double-click the name of the image you want to open.

The Photo CD Options dialog box appears.

Note: If you have the Apple Photo Access extension installed, you will see a
Photos folder as well as the PHOTO_CD folder. The subfolders of each of
these folders contain the same images, although they are organized differently.
The Photo CD Options dialog box appears only when you choose images
from the Images folder inside the PHOTO_CD folder. It is usually preferable
to use these images, because PhotoFlash opens them more quickly and the
Photo CD Options dialog box allows you to size, rotate, and preview the
images before you open them.

6 Choose a set of dimensions from the Resolution pop-up menu.

The dimensions in the Resolution pop-up menu give the image’s width and
height in pixels. In addition to setting the image’s size on screen, these
dimensions determine how much room the file occupies in your computer’s
random-access memory (RAM) after you open it. An additional set of
dimensions appears in the menu if the CD supports Photo CD Pro.

7 Notice the orientation of the image preview in the Photo CD Options dialog box. If the
image is turned on its side and you want to open it right way up, click Rotate 90° Right to
rotate the image clockwise or Rotate 90° Left to rotate it counterclockwise.

The preview shows you the new orientation.
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8 Click Open.

The Photo CD image opens in PhotoFlash with the dimensions and
orientation you selected.

Note: PhotoFlash doesn’t read caption text for Photo CD files.

Acquiring images

You can use PhotoFlash to read image data from an external device such as a
digital camera or scanner. To do so, you must have a plug-in module for the
device you are using. A plug-in module is a special file that conforms to Adobe
Photoshop’s standard plug-in specifications. Some Photoshop plug-in modules
that use other specifications may not work with PhotoFlash. (Note that you
don’t need a plug-in module to use a CD-ROM drive.)

PhotoFlash can use several kinds of plug-in modules. The names of the
Acquire plug-in modules installed in the Plug-ins folder of the PhotoFlash
folder appear in the Acquire submenu of PhotoFlash’s File menu. If your
digital camera, scanner, or other external devices came with a Photoshop
plug-in module, you can install it by dragging the file into the Plug-ins folder.
You must quit PhotoFlash, then launch it again before PhotoFlash can
recognize a newly installed module.

To use the Acquire command, make sure the external device you want to use
is turned on, then follow these steps:

1 Choose the Acquire command from the File menu, but don’t release the mouse button.

The Acquire submenu appears.

IMPORTANT If the Acquire command is dimmed, PhotoFlash has no Acquire
plug-in modules installed. You must have an appropriate plug-in module
installed for the external device you want to use before you can use the
Acquire command.

2 Drag the pointer to the right to choose the plug-in module you want to use from the
Acquire submenu.
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A dialog box appears showing the options for the plug-in module. For
instructions on using the plug-in module, see the documentation that came
with the external device.

For more information about plug-in modules, see Appendix B.

Note: Plug-in modules may or may not be scriptable. For more information,
consult the documentation that comes with each module.

Creating a new image

To create a new, empty image, follow these steps:

1 Choose New from the File menu.

The New dialog box appears.

2 If it’s not already selected, click Image to indicate that you want to create a new image.

3 Select the Image Setup options you want.

4 Click OK.

A new, empty image document appears. The background color for the new
document corresponds to the background color selected in the Preferences
dialog box (see Appendix A for information about PhotoFlash preferences).
You can copy material from other images or other programs and paste it into
this document.

Drag here to choose a different
unit of measurement.
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Viewing images

You can use two tools in the PhotoFlash Tool palette to change your view of
an image within its window. If the Tool palette isn’t visible on your screen,
choose Show Tool Palette from the Window menu to make it appear. The
Hand tool and the Zoom tool, at the top of the palette, allow you to move an
image around within its window and enlarge or reduce it.

The sections that follow describe how to use the Hand and Zoom tools and
how to use the Arrange and Zoom commands in the Window menu. For
information about using the other tools in the Tool palette, see Chapter 3,
“Working With Selections.”

Moving an image within its window

When you’re looking at an image that’s too large to fit in the window, you can
use the Hand tool to move the image around inside the window so you can
see different parts of it. Follow these steps:

1 Click the Hand tool (the tool in the upper-left corner of the Tool palette).

2 Move the pointer over the image you want to move within its window.

The pointer changes to the Hand icon.

3 Hold down the mouse button and drag the image around.

The image moves around within the window, allowing you to examine any
part of it.
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Magnifying or reducing an image

You can use either the Zoom tool (in the Tool palette) or the Zoom command
(in the window menu) to magnify or reduce an image.

Using the Zoom tool

To magnify or reduce an image by using the Zoom tool, follow these steps:

1 Click the Zoom tool (in the top right corner of the Tool palette) to select it. 

If you can’t see the Tool palette, choose Show Tool Palette from the
Window menu.

2 Move the pointer over the image you want to magnify or reduce.

The pointer changes to the Zoom icon with a plus (+) sign inside it.

3 To magnify the image, click within the image window while the Zoom icon contains a
plus sign (+).

PhotoFlash enlarges the image, centering the enlargement on the place
you clicked.

4 To reduce the image, hold down the Option key and click in the image window.

PhotoFlash reduces the image, centering the reduced area on the place
you clicked.

When you hold down the Option key, the plus (+) sign inside the Zoom tool
pointer changes to a minus (–) sign, and clicking on an image reduces it
instead of enlarging it.

Each click of the Zoom tool enlarges or reduces the image by a factor of 2.
The maximum enlargement is 6400%, and the maximum reduction is 1.6%.

5 To return the image to its original size, move the pointer over the Tool palette and
double-click the Zoom tool.

31Working Wi th Image Fi les



Using the Zoom command

To magnify or reduce an image by using the Zoom command, make sure the
image is open and follow these steps:

1 Choose the Zoom command from the Window menu, but don’t release the mouse button.

The Zoom submenu appears. The current enlargement or reduction has a
checkmark beside it in the submenu.

2 Drag the pointer to the right and down to choose the percentage enlargement or
reduction you want.

Fitting an image to the screen

To reduce an image to fit within the window, follow these steps:

1 Choose Zoom from the Window menu, but don’t release the mouse button.

The Zoom submenu appears.

2 Drag to the right and choose Fit to Window from the Zoom submenu.

If the window is too small for the image, PhotoFlash reduces the image to fit
within the window.
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Arranging windows

If you have multiple image windows open at the same time, you can arrange
them automatically by choosing a command from the Arrange menu. Follow
these steps:

1 Choose the Arrange command from the WIndow menu, but don’t release the 
mouse button.

The Arrange submenu appears.

2 Drag the pointer to the right and down to choose the window arrangement you want.

PhotoFlash arranges the image windows as you specified.

If a Get Info or catalog window is frontmost when you choose an Arrange
command, PhotoFlash arranges only the Get Info windows or the catalog
windows.

Adding or editing a caption

You can view information about an image and edit its caption by opening its
Get Info window.

To open the Get Info window for an image in the frontmost window, follow
these steps:

1 Choose Get Info from the File menu.
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The Get Info window for the image appears. You can add or edit caption text
in this window. To locate the image file’s icon on the desktop, click the Find
Original button.

2 When you’re finished, click the Get Info window’s close box to close the window. 

You can also open the Get Info window for an image by selecting its
thumbnail in a catalog and choosing Get Info from the File menu.

Saving an image

You can save any image as a new file, or you can save changes to an existing
image file.

Saving an image as a new file

To save a PhotoFlash image as a new file, follow these steps:

1 Choose Save As from the File menu, but don’t release the mouse button.

34 Chapter  2

Click here to locate the image
file’s icon on the desktop.

Type or edit
caption text here.



2 Drag to the right to choose the file format you want to use from the Save As submenu.

A dialog box appears showing the format options for the file format
you selected.

Note: If the image you’re saving uses fewer than millions of colors or fewer
than 256 grays, you can choose only the PICT or TIFF items in the Save As
submenu; the others are dimmed. You can’t increase the actual number of
colors used by an image, but you can change its setting to a higher number of
colors if you want to save it in one of the dimmed formats. For details, see
“Changing the Number of Colors Used by an Image” in Chapter 4,
“Manipulating Images.”

3 Adjust the settings in the dialog box.

For more information about each file format and its Save As dialog box, see
Chapter 6, “Converting and Compressing Files.”

4 Click Save.
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The Save dialog box appears.

5 Use the dialog box to select a name and location for the file.

PhotoFlash appends a suffix to the default name of the file that reflects the
file format you selected (for example, “/TIFF” for a TIFF file). You can
change the name if you want to.

6 Click Save.

PhotoFlash saves the file in the format you selected with the settings you
selected in step 3.

Saving changes to an existing image file

PhotoFlash allows you to open many kinds of image files and modify them in
various ways. If the original image file is in an image format that PhotoFlash
can save—PICT, TIFF, JPEG, EPS, DCS (for CMYK images only), or formats
supported by Adobe Photoshop plug-in modules installed in PhotoFlash’s
Plug-ins folder—you can save the modified image by choosing Save from the
File menu.

PhotoFlash displays a dialog box before saving the image in the following
cases:

m If the image was pasted onto a new, untitled work area created by choosing
the New command from the File menu.

m If the original image file is in a format that PhotoFlash can open but can’t
save, such as Adobe Photoshop 2.0 or 2.5 or Kodak Photo CD.

m If the original image file is in a format that a PhotoFlash plug-in module
reads but doesn’t write.
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m If the numbers of colors in the original image file have been changed in a
manner that makes it impossible for PhotoFlash to save the image in its
original format (for example, if you have converted a JPEG image with
millions of colors to be displayed using only 256 colors).

If a dialog box appears, it will be a Save As dialog box for the file format
currently specified in PhotoFlash preferences; or, if the preferences specify
Ask instead of a specific file type, a dialog box asking the user to choose a
file format. (For information about setting preferences, see Appendix A,
“Setting PhotoFlash Preferences.”)

If a dialog box appears when you choose Save from the File menu, follow
these steps to save the image as a separate file:

1 Select the settings you want to use in the Save As dialog box.

For more information about the Save As dialog box for each file format, see
Chapter 6, “Converting and Compressing Files.”

2 Click Save.

The Save dialog box appears.

3 If you want to change the file’s name, type the new name in the text box.

4 Use the dialog box to locate the disk or folder where you want to save the image.

5 Click Save.

Reverting to the previously saved version

If you accidentally damage an image, you can easily return the image to the
condition it was in the last time you saved it. To restore the saved version,
choose Revert from the File menu.

Printing images

1 Make sure the image you want to print is the frontmost window.

2 Choose Print from the File menu.
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The Print dialog box appears.

3 Adjust the settings in the Print dialog box as necessary.

4 Click OK.

PhotoFlash prints the image as you specified.

Exporting images

You can use PhotoFlash to export image data to a specialized external device
such as a high-quality printer. To do so, you must have a plug-in module for
the device you are using. A plug-in module is a special file that conforms to
Adobe Photoshop’s standard plug-in specifications. Some Photoshop plug-in
modules that use other specifications may not work with PhotoFlash.

PhotoFlash can use several kinds of plug-in modules. The names of the
Export plug-in modules installed in the Plug-ins folder of the PhotoFlash
folder appear in the Export submenu of PhotoFlash’s File menu. You can
install an Export plug-in module by dragging the file into the Plug-ins folder.
You must quit PhotoFlash, then launch it again before PhotoFlash can
recognize a newly installed module.
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To use the Export command, make sure the external device you want to use is
turned on, then follow these steps:

1 Choose the Export command from the File menu, but don’t release the mouse button.

The Export submenu appears.

IMPORTANT If the Export command is dimmed, PhotoFlash has no Export
plug-in modules installed. You must have an appropriate plug-in module
installed for the external device you want to use before you can use the
Export command.

2 Drag the pointer to the right to choose the plug-in module you want to use from the
Export submenu.

A dialog box appears showing the options for the plug-in module. For
instructions on using the plug-in module, see the documentation that came
with the external device.

For more information about plug-in modules, see Appendix B.
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This chapter describes how to use the Selection tools in the PhotoFlash Tool
palette to select part of an image. After you’ve selected an area, you can use
the Action tools to manipulate or enhance it.

The PhotoFlash Tool palette

You use tools in the PhotoFlash Tool palette to select and modify part of an
image. If the Tool palette isn’t visible on your screen, choose Show Tool
Palette from the Window menu to make it appear.
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You can drag the Tool palette by its top to any convenient location on the
screen. To hide it, click the close box in its upper-right corner or choose Hide
Tool Palette from the Window menu. To select a tool, click it.

The Tool palette contains three groups of tools: the View Tools, the Selection
Tools, and the Action tools. Chapter 2, “Working With Image Files,” describes
how to use the View tools.

IMPORTANT As shown on the previous page, one of the Selection tools can be
selected at the same time as one of the Action tools. The Selection and Action
tools work together. First you select part of the image with one of the
Selection tools, then you use one of the Action tools to manipulate or enhance
the selection.

This figure summarizes how to use each of the Selection tools:

After you select an area, you can perform any of these actions with one of the
Action tools:

Click a selection with the
DeScratch tool to remove 
a scratch.

Click a selection with the DeDust tool
to remove dust.

Click a selection with the 
Sharpen tool to sharpen it.

Click a selection with the Blur tool to
blur it.

Drag a selection with the
Rotate tool to rotate it.

Drag a corner of a selection with the
Resize tool to resize it; hold down the
Shift key to maintain proportions.

Click a selection with the Crop
tool to trim away all of the
image except the selection.

Drag a selection with the Move tool to
move it.

Click an image with the Magic
Wand to select an area of
similar colors.

Drag the Polygon tool to indicate each
side of a polygonal selection; double-
click to complete the selection.

Drag the Lasso tool to select
an irregular area.

Drag the Marquee tool to select 
a rectangle.
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This chapter describes how to use the Selection tools: the Marquee tool, the
Lasso tool, the Polygon tool, and the Magic Wand.

The easiest way to learn how to use the Action tools is to experiment with
them. Duplicate an image to work with, select part of the image, choose an
Action tool, and click or drag in the selection to see what happens.

For more detailed information about the actions the Action tools can perform,
see Chapter 4, “Manipulating Images,” and Chapter 5, “Enhancing Images.”

Selecting a rectangle

To select a rectangle, use the Marquee tool. You can either drag diagonally
across the image to make your selection visually, or you can set a specific size
for the selection first and then click the image to set the selection.

Selecting a rectangle visually

To select a rectangular area, follow these steps:

1 Click the Marquee tool to select it. 

The Marquee tool becomes highlighted, and the pointer changes to a
crosshair when it’s over the image.

2 Move the crosshair pointer to one corner of the area you want to select.

3 Drag diagonally to the opposite corner of the area.

A moving dashed line surrounds the selected area. If the area you selected
isn’t exactly what you want, click outside it (or type x-D) to deselect it and try
again. Alternatively, follow these steps to adjust the selection:

1 Move the pointer over a corner of the selection until the pointer changes to four arrows.
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2 Drag to adjust the selection.

The current dimensions of the selection appear at the bottom of the Tool
palette as you drag.

Selecting a rectangle of a specific size

To specify the size of a rectangular selection before you select it, follow
these steps:

1 Double-click the Marquee tool.

The Rectangle Options dialog box appears.

2 Click the Fixed Size button to activate the Width and Height controls.

If necessary, use the pop-up menus to select different units of measurement.

3 Type the width and height of the rectangle you want to select in the Width and 
Height boxes.

4 Click OK to close the dialog box and confirm your settings.

5 Move the pointer over the image window, press the mouse button, and don’t release it.

A selection rectangle of the size you specified appears. Its upper-left corner is
located where you clicked. You can drag any corner to position the selection.

6 Drag the selection rectangle until it is positioned correctly, then release the 
mouse button.
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IMPORTANT After you select the Fixed Size setting in the Rectangle Options
dialog box, PhotoFlash uses this setting whenever you choose the Marquee
tool. To switch back so you can drag to select a rectangle, double-click
the Marquee tool again, click Normal in the Rectangle Options box, and
click OK.

Selecting an irregular area

To select an irregular area, follow these steps: 

1 Click the Lasso tool to select it.

The Lasso tool becomes highlighted, and the pointer changes to a lasso when
it’s over the image.

2 Drag the lasso around the area you want to select.

You don’t need to drag completely around the area you want to select.
PhotoFlash will complete the selection by drawing a straight line between the
point where you start dragging and the point where you stop. (But if you stop
too soon, you might miss part of what you want to select.)
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Selecting an area in the shape of a polygon

To select an area in the shape of a polygon whose sides aren’t necessarily the
same length, follow these steps:

1 Click the Polygon tool to select it.

The Polygon tool becomes highlighted, and the pointer changes to a crosshair
when it’s over the image.

2 Click at the point where you want to begin the first side of the selection.

3 Without holding down the mouse button, move the crosshair pointer to create one side
of the selection.

4 When the side of the selection is the length you want it, click to fix its length.

5 Repeat steps 3 and 4 for each additional side.

6 To finish selecting the area, double-click the starting point.

If you don’t click the starting point exactly, PhotoFlash completes the
selection by drawing a straight line between the point where you started and
the point where you double-clicked.
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Selecting an area of similar colors (Magic Wand)

To select an area of similar colors by using the Magic Wand tool, you must be
working with an image with 256 grays or thousands or millions of colors or
with a CMYK image. Follow these steps:

1 Click the Magic Wand tool to select it. 

The Magic Wand tool becomes highlighted, and the pointer changes to a
magic wand when it’s over the image.

2 Click the area of similar colors (or grays) you want to select.

A moving dashed line surrounds the selected area.

You can adjust the sensitivity of the Magic Wand tool so that it selects a lesser
or greater range of colors or grays. The greater the range, the larger the
selection is likely to be.

To set the range of colors selected by the Magic Wand tool, follow these steps:

1 Double-click the Magic Wand tool.
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The Magic Wand Options dialog box appears.

2 Drag the Sensitivity slider control to adjust the range of colors to be selected.

The default setting is 15, which selects a relatively narrow range of colors. You
can select any setting from 0 to 255. The lower the number, the fewer the
colors selected by the Magic Wand tool, and the smaller the selection is likely
to be.

At a setting of 0, the Magic Wand selects only colors that are exactly the same
as the color you click.

At a setting of 255, the Magic Wand selects all the colors in the image.

Note: A setting of 0 is good for selecting a completely white background. For
example, if you want to remove a white border from an image, set Sensitivity
to 0; click within the white border with the Magic Wand; choose Invert
Selection from the Edit menu; then click in the colored part of the image with
the Crop tool.

3 Click OK to close the dialog box and confirm your setting.

Changing the area of a selection

After you’ve selected part of an image, you can change the selection by
adding to it or by subtracting from its area.

Adding to a selection

After you’ve selected an area, you can use the Shift key to select additional
separate or overlapping areas. This can be useful if you want to enhance
several odd-shaped areas in the same way, such as by blurring.
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To select several areas of an image and keep them all selected, follow
these steps:

1 Select one area of the image.

2 Hold down the Shift key and select the next area.

You can choose a different Selection tool if you wish. The second selection
may overlap the first selection.

3 Repeat step 2 as many times as you need to.

A moving dashed line surrounds the currently selected areas. If you use
an Action tool anywhere within a selected area, the action affects all the
selected areas.

Subtracting from a selection

After you’ve selected an area, you can use the x key to subtract from the
selection. Follow these steps:

1 Select one part of the image.

2 Hold down the x key and select another area that overlaps your first selection.
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You can choose a different Selection tool if you wish.

When you release the mouse button and x key, PhotoFlash subtracts from the
overall selection the area of the second selection that overlaps the first.

3 Repeat step 2 as many times as you need to.

A moving dashed line surrounds the currently selected area. If you use
an Action tool anywhere within the selected area, the action affects the
whole selection.

Selecting an entire image

To select an entire image, choose Select All from the Edit menu or press x-A.
When the entire image is selected, moving dashed lines surround it.
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Deselecting an area

To deselect the current selection so that no part of the image remains
selected, choose Deselect from the Edit menu or press x-D. If you’re not
using the Magic Wand or the Polygon tool, you can also click outside of the
selected area or in the gray area around the image, if any, to deselect the
current selection.

After you’ve deselected an area, the moving dashed lines around it disappear.

Inverting a selection

When you invert the current selection, everything that was selected becomes
deselected, and everything that was not selected becomes selected.

To invert a selection, choose Invert Selection from the Edit menu. After you
invert a selection, the original selection remains surrounded by moving
dashed lines, but moving dashed lines also surround the entire image.

Inverting a selection can be useful if you want to emphasize one part of an
image by using the Blur tool or some of the other Action tools to make the
rest of the image appear to recede into the background. You can select the
part you want to emphasize, invert the selection so that the part you want to
emphasize becomes deselected and the background becomes selected, then
use the Blur tool or one of the other Action tools to change the selected
background.
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Moving a selection

You can use the Move tool to move or copy a selection. Follow these steps:

1 Select the area you want to move.

2 Click the Move tool to select it. 

3 Position the pointer over the selected area.

4 Drag the selection to reposition it.

If you want to drag a copy of the selection rather than dragging the original,
hold down the Option key while you drag. This causes the area you originally
selected to remain intact after you move the selection.

After you’ve moved the selected area, it remains selected, and you can
perform other operations on it. 

5 When you’re satisfied with the appearance of the selected area in its new location, click
outside the area to deselect it. 

After you deselect it, the moved area replaces any part of the image that’s
underneath it. If you want to undo a move, you have to choose Undo or press
x-Z before you deselect the area.
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You can use commands in the Image menu to crop, resize, straighten, rotate,
or flip an image or to change the number of colors it uses. If part of the image
is currently selected, you can use commands in the Image menu or the
equivalent tools in the PhotoFlash Tool palette to crop the image to the
selection or to resize, rotate, or flip just the selection.

For a quick summary of the way the tools in the Tool palette work, see the
beginning of Chapter 3, “Working With Selections.”

This chapter describes in detail how to manipulate images by using
commands in the Image menu and how to manipulate selections by using the
Crop, Resize, and Rotate tools in the PhotoFlash tool palette. For information
about using commands in the Enhance menu and the other Action tools in the
PhotoFlash Tool palette, see Chapter 5, “Enhancing Images.”

Duplicating an image

Before you begin to experiment on an image with PhotoFlash commands and
tools, it’s usually a good idea to make a copy and make your changes to the
copy. That way you can try out anything you like without danger of losing the
original image. When you’ve finished adjusting the copy to make it look the
way you want, you can save it like any other image file.
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To duplicate the image in the frontmost PhotoFlash image window, just
choose Duplicate from the File menu. An exact duplicate of the image
appears in a new untitled window.

Cropping an image

If you wish to remove some portion of an image, you can select the area you
want to retain and crop (trim away) the rest.

1 Select the part of the image you want to keep.

For information on using the Selection tools, see Chapter 3, “Working With
Selections.”

2 Choose Crop from the Image menu.

Or click the Crop tool in the Tool palette and then click inside the selected
area to crop the image.
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The area you selected appears in the center of the window. The rest of the
image disappears. If you’re not happy with the crop, choose Undo Crop from
the Edit menu and try again.

3 Use the Save or Save As command from the File menu to save the cropped image file on
your hard disk.

IMPORTANT If you use the Save command, the cropped image replaces the
original image on your hard disk. You won’t see a dialog box asking you to
confirm the changes to the original file..

Resizing an image

You can resize part of an image by using the Resize tool or the entire image
by using the Resize command in the Image menu. The Resize tool changes
the dimensions of a selected area without changing the image’s resolution
when printed or its size on disk. The Resize command in the Image menu
allows you to change the whole image’s dimensions in the same way, and also
allows you to change the image’s resolution and its size on disk.
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IMPORTANT Resizing an image may cause its quality to deteriorate.

Note that the Resize tool and the Resize command work differently from the
Zoom tool or the Zoom command. The Resize tool and the Resize command
change the information stored on disk when you save the file, whereas the
Zoom tool and the Zoom command only magnify or reduce the image on
screen without changing its actual dimensions, resolution, or size on disk.

Resizing part of an image

To reduce or enlarge part of an image, follow these steps:

1 Select the area you want to resize.

For detailed instructions on using the Selection tools, see Chapter 3,
“Working With Selections.”

2 Click the Resize tool in the Tool palette to select it.

The Resize tool becomes highlighted.

3 Position the pointer over the selected area.

The pointer changes to the Resize tool icon.

4 Drag any corner or side of the selection in the direction you want to resize it.

To keep the proportions of the selected area the same while you resize it, hold
down the Shift key right after you first press the mouse button, and keep
holding it down while you drag. If you don’t hold down the Shift key, you are
likely to distort the selected area.
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As you resize the selection, its new dimensions appear at the bottom of the
Tool palette.

If you want to resize a copy of the selection, so that the original selected area
underneath it remains intact, hold down the Option key while you drag.

5 Release the mouse button.

The selected area changes size. If you’re not happy with the results, choose
Undo Resize Selection from the Edit menu and try again.

You can use the Resize tool the same way to resize an entire image: Start by
choosing Select All from the Edit menu, then perform steps 2 through 5.

To change an image file’s uncompressed size on disk or its resolution when
printed, use the Resize command as described in the next section.
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Resizing the entire image

To resize an entire image, use the Resize command in the Image menu. This
command displays a dialog box in which you can indicate the new dimensions
you want for the image by typing a percentage or typing a new width and a
new height. The Resize dialog box also allows you to resize the work area in
which the image appears and to change the image’s resolution and its size.

The dimensions of an image, its resolution when printed, and its size on disk
are interrelated. An image consists of a grid of pixels, or dots. The more dots
per square inch, the higher the resolution and overall quality of the image,
and the more room it occupies in memory and on disk (before compression
is applied).

Most monitors display images at a fixed resolution of about 72 dots per inch
(dpi). For this reason, the size of an image displayed on screen may differ
from its size when printed. For example, an image that measures 5 by 3.5
inches on a 72-dpi monitor measures about 2.5 by 1.75 inches when printed
at 150 dpi.

The sections that follow describe how to use the Resize dialog box to change
an image’s dimensions, the dimensions of an image’s work area, or an image’s
resolution. You can choose Undo Resize from the Edit menu after any of these
operations if you’re not happy with the results.

Changing an image’s dimensions

You can use the Resize command to change the dimensions of a single image
or of multiple images represented by selected catalog thumbnails. This
section describes how to resize a single image.

To change an image’s dimensions, make sure the window you want the Resize
command to affect is the frontmost window, then follow these steps:

1 Choose Resize from the Image menu.

The Resize dialog box appears.
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2 If it’s not already selected, click the Image button.

3 Click the Preserve Proportions checkbox to select or deselect it.

If the Preserve Proportions checkbox is selected, the image’s width and height
stay in proportion—if you change one, the other changes automatically by the
same proportion.

If the Preserve Proportions checkbox isn’t selected, you can distort the image
by changing only one dimension or by changing each dimension by a
different proportion.

Select this checkbox to
preserve the uncompressed
size of the image.
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4 Click the Preserve Size checkbox to select or deselect it.

If the Preserve Size checkbox is selected, the uncompressed size of the image
(labeled New Size in the dialog box) won’t change, no matter how much
larger or smaller you make its dimensions. Changing the image’s dimensions
changes its resolution only.

If the Preserve Size checkbox isn’t selected, the uncompressed size of the
image (labeled New Size in the dialog box) changes when you change the
image’s dimensions.

5 Define the new dimensions you want for the image by typing a percentage in the Percent
box or typing new dimensions in the Width and Height boxes.

The Percent box is always set to 100 when you first open the dialog box.
When you type a new number, the Width and Height boxes also change to
show the size of the image at that percentage.

Alternatively, you can type the new dimensions you want in the Width and
Height boxes. If the Preserve Proportions checkbox is selected, changing one
automatically changes the other.

When you define the image’s new dimensions, either the Resolution number
(if the Preserve Size checkbox is selected) or the New Size number (if the
Preserve Size checkbox isn’t selected) also changes automatically.

IMPORTANT If Preserve Size isn’t selected and you increase the image’s
dimensions, it will use more disk space when you save it. Make sure you have
enough space available.

6 Click OK to close the Resize dialog box and initiate the resizing.

PhotoFlash resizes the image, ignoring any selection the image contains.

If you’re resizing multiple images whose thumbnails are selected in a catalog,
PhotoFlash opens the images (if they’re not already open) and resizes each
one.
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To confirm that the new dimensions of an image have been set as you
intended, follow these steps:

1 Position the pointer over the number in the lower-left corner of the image window.

2 Press the mouse button.

Changing the dimensions of an image’s work area

An image file can include an extra space around the image itself called the
work area. The work area is actually part of the image; the only difference is
that its pixels are a uniform color determined by a setting in the Preferences
dialog box (white by default). You can use the Resize command to change the
dimensions of the work area. For example, if you want to include two pictures
in one image file, you might want to enlarge the work area to make room for
the second picture.

If you make the work area larger, white pixels are added around the
boundaries of the image. If you make the work area smaller than the image
itself, the image is cropped accordingly. Changing the dimensions of an
image’s work area always changes the uncompressed size of the image file.

You can only change the work area of a single image; you can’t change the
work area of images represented by selected catalog thumbnails.

To resize a single image’s work area, make sure the window you want the
command to affect is the frontmost window, then follow these steps:

1 Choose Resize from the Image menu.

The Resize dialog box appears.
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2 If it’s not already selected, click the Work Area button.

3 Click the Preserve Proportions checkbox to select or deselect it.

If the Preserve Proportions checkbox is selected, the width and height must
stay in proportion—if you change one, the other changes automatically by the
same proportion.

If the Preserve Proportions checkbox isn’t selected, you can change the work
area’s vertical and horizontal dimensions in any way you like.

4 Define the new dimensions you want for the work area by typing a percentage in the
Percent box or typing new dimensions in the Width and Height boxes.

The Percent box is always set to 100 when you first open the dialog box.
When you type a new number, the Width and Height boxes also change to
show the size of the work area at that percentage.

Alternatively, you can type the new dimensions you want in the Width and
Height boxes. If the Preserve Proportions checkbox is selected, changing one
automatically changes the other.
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When you define the work area’s new dimensions, the New Size figure (which
indicates what the image’s uncompressed size will be after you save it) also
changes automatically.

IMPORTANT If you increase the work area’s dimensions, it will use more disk
space when you save it. Make sure you have enough space available.

5 If you’re enlarging the image’s work area, click one of the squares in the upper-right
corner of the dialog box to indicate approximately where you want the image located
within the new work area.

6 Click OK to close the Resize dialog box and initiate work area resizing.

PhotoFlash resizes the work area.

Changing an image’s resolution

You can use the Resize command to change the resolution of a single image or
of multiple images represented by selected catalog thumbnails. Resolution is
usually expressed in dots per inch (dpi)—that is, the number of pixels in a 1-
inch-high column of pixels. An image’s resolution may differ from the
resolution at which it is displayed. For this reason, the size of an image
displayed on screen may differ from its size when printed. For example, an
image that measures 5 by 3.5 inches on a 72-dpi monitor measures about 2.5
by 1.75 inches when printed at 150 dpi.

Some printers and other devices produce better results if the images they
print are set to a specific resolution. For best results, follow the directions
regarding resolution in the documentation that comes with the printer or other
output device. The general rule of thumb is that the image resolution should
be no more than half of the printer’s resolution, as suggested by this table.

For the best results in: Set the image file resolution to:

Displaying images on computer screen, like desktop presentations 72 dpi

Printing images on most laser printers (300 dpi) 150 dpi

Printing images on higher-end laser printers (600 dpi) 300 dpi

Creating image output for film production 600 dpi

Printing on very high end print production printers 2400 dpi
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To change the resolution of a single image, make sure the window you
want the Resize command to affect is the frontmost window, then follow
these steps:

1 Choose Resize from the Image menu.

The Resize dialog box appears.

2 If it’s not already selected, click the Image button.

3 Click the Preserve Size checkbox to select or deselect it.

If the Preserve Size checkbox is selected, the uncompressed size of the image
(labeled New Size in the dialog box) won’t change, no matter how you change
its resolution. Changing the image’s resolution changes its dimensions only.

If the Preserve Size checkbox isn’t selected, the uncompressed size of the
image (labeled New Size in the dialog box) changes when you change the
image’s resolution.

4 Define the new resolution you want for the image by typing a number in the Resolution
box or choosing a resolution from the Resolution pop-up menu.

When you define a new resolution for a single image, either the Width and
Height boxes change to show the image’s new dimensions (if the Preserve
Size checkbox is selected) or the New Size number changes to indicate the
uncompressed size of the image (if the Preserve Size checkbox isn’t selected).
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IMPORTANT If Preserve Size isn’t selected and you increase the image’s
resolution, it will use more disk space when you save it. Make sure you have
enough space available.

5 Click OK to close the Resize dialog box and initiate the resolution change.

PhotoFlash changes the image’s resolution, ignoring any selection the image
may contain.

If you’re resizing multiple images whose thumbnails are selected in a catalog,
PhotoFlash opens the images (if they’re not already open) and changes the
resolution of each one.

Straightening an image

If an image wasn’t exactly straight straight on the scanner when it was
scanned, or if the camera used to take a picture wasn’t level, or if for any
reason you want to straighten an entire image within its window, you can use
the Straighten command to do so. Follow these steps:

1 Make sure the window for the image you want to straighten is the frontmost window.

2 Choose Straighten from the Image menu.

A cross with a circle in its center appears over the image. If you’ve previously
selected any part of the image, the selection disappears. (It will reappear in
the corresponding part of the straightened image.).

If you change your mind and decide you don’t want to straighten the image
after all, choose Cancel Straighten from the Image window, press the Escape
(Esc) key, or press x-period.
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3 Drag the circle in the center of the cross to define the axis around which you want to
rotate the image.

A convenient point for the axis of rotation in this picture is the bottom of the
big tree’s trunk, as shown above.

4 Release the mouse button.

5 Move the pointer along any of the crossbar’s arms.

The pointer changes to a small curve with arrows at both ends.
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6 Hold the mouse button down and drag until the crossbars align with elements in the
image that you want to be vertical or horizontal.

In this example, the horizontal crossbar has been aligned with the hillside and
the vertical crossbar has been aligned with the tree, so that the tree will look
like it’s growing straight up out of flat ground after the image is straightened.

7 Move the pointer over any part of the image that’s away from the crossbars and click.

After a moment, PhotoFlash rotates the image around the point you specified
in step 3. If necessary, the work area enlarges to accommodate the entire
straightened image.

Rotating an image

You can rotate part of an image by using the Rotate tool, or you can rotate the
entire image by using the Rotate command in the Image menu. You can also
use the Straighten command to rotate an entire image as described in the
previous section. Use the Straighten command when you want to align the
image horizontally or vertically, and the Rotate command when you want to
rotate the image a specific number of degrees.
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Rotating part of an image

To rotate part of an image, follow these steps:

1 Select the part of the image you want to rotate.

For instructions on using the Selection tools, see Chapter 3, “Working With
Selections.”

2 Click the Rotate tool in the Tools palette to select it.

The Rotate tool becomes highlighted.

3 Position the pointer over the selected area.

The pointer changes to a tightly curved arrow.

4 Drag any corner of the selection in the direction you want to rotate it.

As you rotate the selection, the angle measurement at the bottom of the Tool
palette changes.

If you want to rotate a copy of the selection, so that the original area
underneath it remains intact, hold down the Option key while you drag.

5 Release the mouse button when you’ve rotated the selection to the desired angle.
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Rotating an entire image

You can rotate an image in 90° increments: 90° left, 90° right, or a full 180°.
You can also specify an arbitrary number of degrees that you want the image
to be rotated.

You can use the Rotate command on a single image that’s open in PhotoFlash
or on one or more thumbnails selected in a catalog window. If you want to
use the Rotate command on thumbnails in a catalog, make sure the catalog is
the frontmost window and that the thumbnails whose images you want to
rotate are selected before you follow the steps presented here.

To rotate images in 90° increments, follow these steps:

1 Choose Rotate from the Image menu, but don’t release the mouse button.

2 Drag to the right to choose one of the three preset Rotate commands.

After you release the mouse button, Photoflash rotates the image or images as
you specified. (If the images represented by selected catalog thumbnails aren’t
open, PhotoFlash opens them first.)
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To rotate images an arbitrary number of degrees, follow these steps:

1 Choose Rotate from the Image menu, but don’t release the mouse button.

2 Drag to the right to choose the Arbitrary command.

After you release the mouse button, the Rotate dialog box appears.

3 Type the number of degrees you want to rotate the image and click Right or Left to
indicate the direction of rotation.

4 Click OK to rotate the image.

If necessary, the work area enlarges to accommodate the entire rotated image.

If the frontmost window contains a single image and part of the image is
selected, the Rotate command rotates only the selected area. If the frontmost
window contains a catalog with several thumbnails selected, the Rotate
command ignores any selections the images contain.
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Flipping an image

You can flip part of an image or the whole image by using the Flip command
in the Image menu. This can be useful, for example, if you want to place a
picture on a page with the person in it facing left, but the person faces right in
the original image.

To flip part or all of an image, follow these steps:

1 If you want to flip just part of an image, first select the part.

If you want to flip the whole image, skip this step. For detailed instructions on
using the Selection tools, see Chapter 3, “Working With Selections.”

2 Choose Flip from the Image menu, but don’t release the mouse button.

3 Drag to the right to choose Horizontally or Vertically.

After you release the mouse button, Photoflash flips the image or, if part of
the image is selected, the selection.

To flip multiple images at a time from within a catalog, select their
thumbnails and repeat steps 2 and 3. If image files for the selected thumbnails
aren’t already open, PhotoFlash opens and flips them. If image files for the
selected thumbnails are already open, PhotoFlash flips them. In both cases
PhotoFlash ignores any selections the images contain.

71Manipulat ing Images



Changing the number of colors used by an image

A digitized image consists of a grid of pixels, or dots. You can use the
Number of Colors command in the Image menu to control how many
different colors each pixel is capable of representing. This number directly
affects the fidelity of the image, especially in the case of photographic or
other continuous-tone images.

If a single pixel can represent only black or white, it occupies very little space
on disk, but it can give only a rough approximation of any grays or colors in
the original image. At the other extreme, if a single pixel can represent one of
millions of colors, it occupies much more space on disk, but it is likely to give
a very good approximation of any colors or grays in the original.

IMPORTANT The number of colors used by an image may differ from the
number of colors you can actually see on screen, which depends on the kind
of monitor you have and the current setting for that monitor in the Monitors
control panel. For example, on a black-and-white monitor an image that uses
millions of colors displays only white or black pixels, because that’s all 
the monitor can display. The Number of Colors command controls only
the number of colors used internally to represent an image’s pixels, not the
number of colors used by your monitor.

The next section describes how to use the Number of Colors command.
“Deciding How Many Colors to Use,” later in this chapter, describes some of
the issues you should consider if you’re not sure how many colors to use for a
particular image.

Using the Number of Colors command

Before you change the number of colors used by an image, it’s a good idea
to use the Duplicate command in the File menu to create a copy of the image
in a new window. This ensures that you can retrieve the original version of
the image no matter what you do to the copy. Otherwise, if you reduce the
number of colors used by the original image and use the Save command
to save the new version, the original information about the image’s colors is
gone forever.
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To change the number of colors used by an image, follow these steps:

1 Choose Number of Colors from the Image menu.

The Number of Colors dialog box appears.

If you click anywhere in an image while this dialog box is open, the part of
the image you click appears in the Before and After boxes.

2 Select the number of colors you want the image to use.

IMPORTANT You can’t increase the actual number of colors used by an image,
but you can increase the setting for this number in the Number of Colors
dialog box. This can be useful when you’re converting image files between
different formats. Note that increasing the number of colors always increases
the image’s size on disk, even though the actual number of colors used by each
pixel doesn’t change.
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For help deciding which setting to use for a specific image, see the next
section, “Deciding How Many Colors to Use.”

3 If you want the image to be dithered, make sure the Dithered checkbox is selected.

You can select the Dithered checkbox only if you are reducing the number of
colors used by the image. A dithered image is displayed using a technique that
changes the colors of some adjacent pixels to create the illusion of more
colors. For example, dithering can give the effect of shades of gray in a black-
and-white image or of additional colors in a color image.

You may want to experiment with the Dithered option and see how it affects
the view labeled After in the dialog box. In many cases (but not all), dithering
improves an image’s appearance.

4 Click Change.

The image information changes as you specified. If you don’t like the change,
choose Undo Depth Change from the Edit menu and try again.

Deciding how many colors to use

If you’re not sure how many colors (or shades of gray) to use for a particular
image, keep these general guidelines in mind:

m Reducing the number of colors used by an image decreases its size when
saved to disk, but it may also reduce the image’s quality when displayed on
screen or printed.

m Reducing the number of colors used by an image may mean that it prints
more quickly, but (depending on the printer you’re using) it doesn’t
necessarily reduce the print quality.

Some file formats limit the number of colors (or shades of gray) that images
saved in those formats can use. The section “Number of Colors or Grays
Supported by Standard File Formats” in Chapter 6 lists the number of colors
or grays you can specify for the standard file formats supported by
PhotoFlash.
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You can use commands in the Enhance menu to adjust the color balance,
exposure, brightness, and contrast of an image; to blur or sharpen it; and to
remove dust or scratches. You can also use most of the Enhance commands
on selected thumbnails in a catalog.

If you are using any Enhance command on a single image and part of the
image is currently selected, the command affects only the selection. In some
cases you can use an equivalent tool in the PhotoFlash Tool palette as an
alternative to using an Enhance command. For a quick summary of the way
the tools in the Tool palette work, see the beginning of Chapter 3, “Working
With Selections.”

This chapter describes in detail how to enhance images by using the standard
Enhance commands and how to enhance selections by using the Blur,
Sharpen, DeDust, and DeScratch tools. If you have installed any Photoshop-
compatible plug-in modules in the PhotoFlash Plug-ins folder, additional
commands that aren’t described here may show up in the Enhance menu.
Such commands work much like the standard Enhance commands. See the
documentation that came with the plug-in modules for more information.
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Using the Enhance commands

This section summarizes how the standard Enhance menu commands work.
The sections that follow describe in more detail the actions you can perform
with each command and, where appropriate, how to use the equivalent tool in
the PhotoFlash Tool palette.

To enhance a single image or a group of images represented by selected
catalog thumbnails, make sure the window you want the command to affect is
frontmost and then follow these steps: 

1 Choose the command you want to use from the Enhance menu.

The Enhance dialog box for the command appears. This is what it looks like
for the Brightness/Contrast command:

If you are working with a single image, the dialog box includes Before and
After views of the image. If you click on the image itself while this dialog box
is open, the place you click appears in the Before and After boxes.

If you are working with more than one thumbnail in a catalog, the dialog box
doesn’t include Before and After images.
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2 Adjust the sliders as necessary to achieve the kind of enhancement you want.

If you are working with a single image, you can try out new settings and view
their effects, and you can use the Hand and Zoom tools to move, enlarge, or
reduce the view of the image.

3 If you can’t achieve the look you want, try experimenting with other commands in the
Enhancement pop-up menu.

The commands in the Enhancement pop-up menu are the same as the
standard commands in the Enhance menu. (Enhance commands provided by
plug-in modules may not show up in the pop-up menu.) When you choose a
different command, the Enhance dialog box displays the controls for that
command.

If you change your mind about the enhancement, click Cancel.

4 Click Enhance when you’re ready to apply the current enhancement settings.

PhotoFlash applies the current enhancement settings to the current selection,
if any, or to the entire image in the frontmost window, or to the images
represented by selected thumbnails in the frontmost window. If any of the
images represented by selected thumbnails are currently open, PhotoFlash
applies the enhancement to each image as a whole and ignores any selections
the images contain.

If you’re not happy with the results, choose Undo from the Edit menu and
try again.

Adjusting colors

Most image files contain information about each pixel’s color in the form of
numbers that represent the proportions of red, green, and blue that combine
to make a specific color. You can use the Adjust Colors command in the
Enhance menu to increase or decrease the proportion of red, green, or blue
for all the pixels in a selection, in an image, or in a group of images identified
by selected catalog thumbnails.

The Adjust Colors command works only for images with millions of colors.
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Make sure the window you want the Adjust Colors command to affect is
frontmost, then follow these steps:

1 Choose Adjust Colors from the Enhance menu.

The Enhance dialog box appears.

If you click on the image itself while this dialog box is open, the place you
click appears in the Before and After boxes.

2 Adjust the Red, Green, and Blue sliders as necessary to adjust the image’s colors to
your satisfaction.

3 When you’re ready to apply the color adjustments, click Enhance.

PhotoFlash applies the color adjustment settings you specified to the
frontmost window. If the window contains an image that includes a selection,
PhotoFlash applies the new settings to the selection only. If the window
contains a catalog with selected thumbnails, it applies the new settings to the
images they represent and ignores any selections the images contain.
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Balancing the exposure

You can use the Balance Exposure command in the Enhance menu to bring
out details in an image that are otherwise faint or even invisible. In general,
it’s preferable to balance the exposure of a whole image rather than a selected
area of an image. This command may improve severely overexposed or
underexposed images that can’t be fixed with the Brightness/Contrast
command.

Make sure the window you want the Balance Exposure command to affect is
frontmost, then follow these steps:

1 Choose Balance Exposure from the Enhance menu.

The Enhance dialog box appears.

If you click on the image itself while this dialog box is open, the place you
click appears in the Before and After boxes.

2 Adjust the Sensitivity and Blending sliders as necessary to achieve the exposure 
you want.

3 When you’re ready to apply the exposure settings, click Enhance.
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PhotoFlash applies the exposure settings you specified to the frontmost
window. If the window contains an image that includes a selection,
PhotoFlash applies the new settings to the selection only. If the window
contains a catalog with selected thumbnails, PhotoFlash applies the
new settings to the images they represent and ignores any selections the
images contain.

Adjusting brightness and contrast

You can use the Brightness/Contrast command in the Enhance menu to adjust
the brightness and contrast of a selected area, a single image, or multiple
images represented by selected catalog thumbnails.

Make sure the window you want the command to affect is frontmost, then
follow these steps: 

1 Choose Brightness/Contrast from the Enhance menu.

The Enhance dialog box appears.

If you click on the image itself while this dialog box is open, the place you
click appears in the Before and After boxes.

2 Adjust the Brightness and Contrast slider as necessary to achieve the look you want.
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Some general guidelines for adjusting brightness and contrast follow step 3.

After you adjust the Brightness slider, click different areas of the image to
examine the changes in the brightest and darkest areas. If you move the slider
too far to the right, very light areas change to pure white and lose all detail. If
you move the slider too far to the left, very dark areas change to pure black
and lose all detail.

It’s also a good idea to examine the light and dark areas of the preview image
after you adjust the Contrast slider. If you increase contrast, lighter areas
become brighter and darker areas become darker. If you decrease contrast,
lighter areas become darker and darker areas become lighter.

3 When you’re ready to apply the new settings, click Enhance.

PhotoFlash applies the brightness and contrast settings you specified to the
frontmost window. If the window contains an image that includes a selection,
PhotoFlash applies the new settings to the selection only. If the window
contains a catalog with selected thumbnails, PhotoFlash applies the new
settings to the images they represent and ignores any selections the images
contain.

Every image you attempt to adjust with the Brightness/Contrast command is
likely to require slightly different settings for optimal quality. Finding the
right settings is usually a matter of trial and error, but keep these guidelines in
mind as a starting point for your adjustments:

If the image appears to be

m too dark, increase the brightness and then experiment with changing
the contrast.

m too light, decrease the brightness and then experiment with changing
the contrast.

m too gray, increase the contrast and then experiment with changing
the brightness.

m too high contrast, decrease the contrast and then experiment with changing
the brightness.

If you can’t improve an image by adjusting its brightness and contrast, try the
Balance Exposure command.
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Blurring an image

You can use either the Blur command or the Blur tool to blur or soften part of
an image or an entire image, making it appear to be less in focus. The Blur
command is more convenient if you’re blurring the whole image, and it gives
you a preview of the change before you apply it. You can also use the Blur
command to blur multiple images represented by selected catalog thumbnails.
The Blur tool is sometimes convenient if you’re blurring just part of an image.

PhotoFlash blurs images by blending the colors of neighboring pixels. Both
the Blur command and the Blur tool allow you to adjust the amount of
blurring applied at one time. If you select the minimum amount, PhotoFlash
blends only immediately adjacent pixels, producing a subtle softening of the
image. As you increase the amount of blurring, PhotoFlash blends more and
more pixels until the image becomes unrecognizable.

Using the Blur command

To use the Blur command on part of an image, an entire image, or multiple
images represented by selected catalog thumbnails, make sure the window
you want the command to affect is frontmost, then follow these steps:

1 Choose Blur from the Enhance menu.

The Enhance dialog box appears.
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If you click on the image itself while this dialog box is open, the place you
click appears in the Before and After boxes.

2 Adjust the slider as necessary to achieve the look you want.

3 When you’re ready to apply the new setting, click Enhance.

PhotoFlash applies the Blur setting you specified to the frontmost window. If
the window contains an image that includes a selection, PhotoFlash blurs the
selection only. If the window contains a catalog with selected thumbnails,
PhotoFlash blurs the images they represent and ignores any selections the
images may contain.

Using the Blur tool

To blur part of an image using the Blur tool, follow these steps:

1 Select the part of the image you want to blur.

For instructions on using the Selection tools, see Chapter 3, “Working With
Selections.” To select the entire image, choose Select All from the Edit menu.

2 If you want to adjust how much the Blur tool blurs, double-click it; otherwise, skip to
step 4.

The Blur Options dialog box appears.

3 Adjust the Blur Options setting as necessary, then click OK .

4 If it’s not already selected, click the Blur tool in the Tools palette to select it. 

The Blur tool becomes highlighted when it’s selected.

Drag this slider to increase or
decrease the Blur tool’s effect.
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5 Position the pointer over the part of the image you selected.

The pointer changes to the Blur icon.

6 Click anywhere in the selected area.

PhotoFlash blurs the selected area. 

Sharpening an image

You can use either the Sharpen command or the Sharpen tool to sharpen an
image. The Sharpen command is usually more convenient if you’re
sharpening the whole image, and it gives you a preview of the change before
you apply it. You can also use the Sharpen command to sharpen multiple
images represented by selected catalog thumbnails. The Sharpen tool is
sometimes convenient if you’re sharpening just part of an image.

Because many printers tend to blur images slightly, sharpening an image
slightly before printing can yield better results. Note, however, that some
printers sharpen images automatically.

Sharpening an image doesn’t add any detail to it. Instead, PhotoFlash
analyzes the contents of the area to be sharpened and emphasizes the
differences between the colors of adjacent pixels. Both the Sharpen command
and the Sharpen tool allow you to adjust the degree of sharpening. You
should keep this adjustment as low as possible. Sharpening may produce
unwanted effects if you apply it at too high a setting.

Using the Sharpen command

To sharpen part of an image, an entire image, or multiple images represented
by selected catalog thumbnails, follow these steps:

1 Choose Sharpen from the Enhance menu.



The Enhance dialog box appears.

If you click on the image itself while this dialog box is open, the place you
click appears in the Before and After boxes.

2 Adjust the slider as necessary to achieve the look you want.

For best results, keep the setting as low as possible.

3 When you’re ready to apply the new setting, click Enhance.

PhotoFlash applies the Sharpen setting you specified to the frontmost
window. If the window contains an image that includes a selection,
PhotoFlash sharpens the selection only. If the window contains a catalog with
selected thumbnails, PhotoFlash sharpens the images they represent and
ignores any selections the images may contain.

Using the Sharpen tool

To sharpen part of an image by using the Sharpen tool, follow these steps:

1 Select the part of the image you want to sharpen.

For instructions on using the Selection tools, see Chapter 3, “Working With
Selections.” To select the entire image, choose Select All from the Edit menu.
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2 If you want to adjust how much the Sharpen tool sharpens, double-click it; otherwise,
skip to step 4.

The Sharpen Options dialog box appears.

3 Adjust the Sharpen setting as necessary, then click OK.

For best results, keep the setting as low as possible.

4 If it’s not already selected, click the Sharpen tool in the Tools palette to select it. 

The Sharpen tool becomes highlighted when it’s selected.

5 Position the pointer over the part of the image you selected.

The pointer changes to the Sharpen icon.

6 Click anywhere in the selected area.

PhotoFlash sharpens the selected area.

Removing dust

You can use either the Remove Dust command or the DeDust tool to remove
dust from a selected area or an entire image. Both methods work best if you
carefully select the part of the image from which you want to remove dust.
Otherwise, PhotoFlash may interpret part of the image itself as dust and
remove details you don’t want removed.
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The Remove Dust command allows you to preview its changes before you
make them, which can be helpful when you’re trying to find the right settings
to remove dust that blends in with the background. It’s not a good idea to use
the Remove Dust command to remove dust from multiple images represented
by selected thumbnails, because the command ignores selections and instead
acts on the whole image.

Using the Remove Dust command

The Remove Dust command, like the DeDust tool, works best if you first
carefully select the part of the image from which you want to remove dust.
Follow these steps:

1 Select the part of the image from which you want to remove dust.

For instructions on using the Selection tools, see Chapter 3, “Working With
Selections.”

2 Choose Remove Dust from the Enhance menu.

The Enhance dialog box appears.

3 Adjust the sliders as necessary to remove the dust. 
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Try fairly low settings first, and check the Before and After views to see their
effect. The lower the Size setting, the smaller the specks that PhotoFlash
recognizes as dust. The lower the Sensitivity setting, the more different a
speck’s color must be from surrounding colors for PhotoFlash to recognize it
as dust. Lower sensitivity also tends to reduce the number of image elements
that PhotoFlash recognizes as dust.

4 When you’re ready to try removing the dust, click Enhance.

PhotoFlash attempts to remove the dust as you specified. Because PhotoFlash
can’t always distinguish between dust and part of the original image, it may
not always be able to remove dust successfully without altering the image
itself.

Using the DeDust tool

To remove dust from part of an image by using the DeDust tool, follow
these steps:

1 Select the part of the image from which you want to remove dust.

For instructions on using the Selection tools, see Chapter 3, “Working
With Selections.”

2 If you want to adjust the dust size and sensitivity settings for the DeDust tool, double-
click it; otherwise, skip to step 4.

The Remove Dust Options dialog box appears.
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3 Adjust the Size and Sensitivity settings as necessary, then click OK. 

Try fairly low settings first, increasing them only if the dust doesn’t disappear
when you click the selection. To see the effects different settings have, use the
Remove Dust command as described in the previous section.

4 If it’s not already selected, click the DeDust tool in the Tool palette to select it. 

The DeDust tool becomes highlighted when it’s selected.

5 Position the pointer over the part of the image you selected.

The pointer changes to the DeDust icon.

6 Click anywhere in the selected area.

PhotoFlash attempts to remove dust from the selected area. If you have
trouble removing dust with the DeDust tool, you may find it easier to use the
Remove Dust command as described in the previous section. The Remove
Dust command allows you to preview part of an image while you adjust the
Remove Dust Options dialog box.

Removing scratches

You can use either the Remove Scratch command or the DeScratch tool to
remove scratches from a selected area or an entire image. Both methods work
best if you carefully select the scratch you want to remove, including as little
of the rest of the image as possible. Otherwise, PhotoFlash may interpret part
of the image itself as a scratch and remove details you don’t want removed. If
you find you don’t get good results after selecting a scratch with the Marquee
tool, try the Lasso tool.

The Remove Scratch command allows you to preview its changes before you
make them, which can be helpful when you’re trying to find the right settings
to remove a scratch that blends in with the background. It’s not a good idea to
use the Remove Scratch command to remove scratches from multiple images
represented by selected thumbnails, because the command ignores selections
and instead acts on the whole image.
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Using the Remove Scratch command

The Remove Scratch command, like the DeScratch tool, works best if you
first carefully select the part of the image from which you want to remove a
scratch. Follow these steps:

1 Select the part of the image from which you want to remove a scratch.

For instructions on using the Selection tools, see Chapter 3, “Working
With Selections.”

2 Choose Remove Scratch from the Enhance menu.

The Enhance dialog box appears.

3 Adjust the sliders as necessary to remove the scratch.

Try fairly low settings first. Check the Before and After views to see the effect
of changing the settings. The higher the Width setting, the wider a scratch can
be for PhotoFlash to recognize it as a scratch. The higher the Sensitivity
setting, the more image elements PhotoFlash interprets as scratches.

If you raise either of these settings too high, PhotoFlash may interpret valid
elements of the image such as trees, poles, or wallpaper patterns as scratches.
Always use the lowest settings that remove the scratches on your image.
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4 When you’re ready to try removing the scratch, click Enhance.

PhotoFlash attempts to remove the scratch as you specified.

Using the DeScratch tool

To remove a scratch from part of an image by using the DeScratch tool,
follow these steps:

1 Select the part of the image from which you want to remove a scratch.

For instructions on using the Selection tools, see Chapter 3, “Working
With Selections.”

2 If you want to adjust the Width and Sensitivity settings for the DeScratch tool, double-
click it; otherwise, skip to step 4.

The Remove Scratch Options dialog box appears.

3 Adjust the Width and Sensitivity settings as necessary, then click OK .

Try fairly low settings first, increasing them only if the scratch doesn’t
disappear when you click the selection. To learn more about the effects
different settings have, use the Remove Scratch command as described in the
next section.

4 If it’s not already selected, click the DeScratch tool in the Tools palette to select it. 

The DeScratch tool becomes highlighted when it’s selected.

91Enhancing Images

Double-click the DeScratch tool in
the Tool palette to adjust its settings.

Drag this slider to increase or
decrease the width of the marks that
PhotoFlash interprets as scratches.

Drag this slider to
increase or decrease

the sensitivity of the
DeScratch tool.



5 Position the pointer over the part of the image you selected.

The pointer changes to the DeScratch icon.

6 Click anywhere in the selected area.

PhotoFlash attempts to remove scratches from the selected area. If you have
trouble removing a scratch with the DeScratch tool, you may find it easier to
use the Remove Scratch command as described in the previous section. The
Remove Scratch command allows you to preview part of an image while you
adjust the Remove Scratch Options dialog box.

Repeating enhancements

You can use the Repeat command to apply an enhancement again and again.
For example, if you click a selected area of an image with the Blur tool and
the area still isn’t blurry enough for you, you can choose Repeat Blur from the
Enhance Menu to blur the area again.

The Repeat command refers by name to the enhancement that you most
recently chose from the Enhance menu or applied with a tool from the Tool
palette. If you haven’t applied an enhancement since you opened PhotoFlash,
the Repeat command changes to Can’t Repeat and is dimmed.
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PhotoFlash can open and save image files in a variety of formats. This means
you can use PhotoFlash to convert image files saved in one format to another
format. Most image file formats also allow you to compress an image file so
that it doesn’t take up as much room on disk when you save it. 

This chapter describes how to convert image files from one format to another.
It discusses the five standard file formats supported by PhotoFlash and
describes how to use JPEG compression, which is a standard format for
image compression that can be used with most file formats.

If you have installed any Photoshop-compatible plug-in modules in the
PhotoFlash Plug-ins folder, additional file formats that aren’t described here
may show up in the Save As submenu. See the documentation that came with
the plug-in modules for information about using them.
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Converting image file formats

The basic procedure for converting image file formats is the same for all the
file formats supported by PhotoFlash: You use the Save As command to select
a different format, adjust the settings in the Save As dialog box for that
format, and save the image.

To convert an image file to a different file format, make sure the image you
want to convert is open in the frontmost window, then follow these steps:

1 Choose Save As from the File menu, but don’t release the mouse button

2 Drag to the right to choose the file format you want to use from the Save As submenu

The dialog box for the file format you selected appears.

Note: Depending on the number of colors the image you are saving uses, the
names of some file formats may be dimmed. See “Changing the Number of
Colors Used by an Image” in Chapter 4 for more information.

3 Adjust the settings in the dialog box.

The options for each of the standard formats supported by PhotoFlash are
described in the next section, “Choosing a File Format.”
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4 Click Save.

The Save dialog box appears.

5 Use the dialog box to name the file and select a location for it.

PhotoFlash appends a suffix to the name of the file that reflects the type of
file format that you selected. You can change this default name if you like.

6 Click Save.

PhotoFlash saves the file in the format you selected with the options you
selected in step 3.

Choosing a file format

This section describes the five standard file formats supported by PhotoFlash.
With the exception of the JPEG format, this section also explains how to use
the dialog box that appears when you choose each file format’s name from the
Save As submenu (see steps 1 and 2 of the preceding section, “Converting
Image File Formats”). For information about using the JPEG format, see
“Using JPEG Compression” later in this chapter.

PICT

The PICT format is the standard Macintosh image file format. All Macintosh
programs that can use color image files support the PICT file format.
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The compression options that can be applied to the image file saved in
the PICT format appear on the PICT Compression pop-up menu in the
Save As PICT dialog box.

IMPORTANT The PICT compression options are available only if the
QuickTime system extension is correctly installed in the System Folder on the
startup drive of your Macintosh. (If you installed QuickTime yourself, don’t
forget to restart your Macintosh.)

The following limitations also apply:

m JPEG compression is available only for image files that have millions of
colors or 256 grays.

m You can’t save a CMYK image as a PICT file.

The PICT Compression pop-up menu includes these options:

m Animation. Use this option if your PICT file will be incorporated as a frame
of a QuickTime animation sequence. This option is good for computer-
generated pictures with large areas of the same color.

m Cinepak. Use this option when working with motion video. Its rapid
decompression allows for fast playback, but recompression is relatively
slow.

m Component Video. Use this option if you are modifying an individual frame
of a QuickTime video sequence.

m Graphics. Use this option if you are working with a split image file or 
an image file that contains mostly solid colors, such as a bar graph or pie
chart. Using this option forces PhotoFlash to use 256 colors and a
compression setting of 50, ignoring the setting on the slider.

m None. Use this option if you don’t want any image compression applied to
the PICT file.
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m Photo–JPEG. Use this option when working with photographic images
generated by a digital video camera or a scanner. Photo-JPEG compression
helps maintain the subtle shades of image detail while creating the
smallest possible PICT image file.

m Video. Use this option if you are modifying an individual frame of a
QuickTime video sequence. This format forces the image to use thousands
of colors.

When you choose any option other than None, the Quality slider in the Save
As PICT dialog box becomes active. Drag the Quality slider control to the
setting you want.

Qualities range from 1 to 100.

A setting of 1 provides the lowest image quality and the most compression
(smallest size of the image file).

A setting of 100 offers the highest image quality and the least compression
(largest size of the image file).

TIFF

TIFF stands for Tagged Image File Format. A TIFF file includes information
about the file’s characteristics that allows many different kinds of computers
to open and interpret the color and image data in the file. For example, PC-
DOS computers and UNIX® workstations can open and use image files saved
in the TIFF file format on a Macintosh.

Virtually all page layout programs support the TIFF file format, and many
recommend using TIFF files when you place or import an image file into a
layout file.
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The compression options that can be applied to an image file saved in the
TIFF format appear on the TIFF Compression pop-up menu in the Save As
TIFF dialog box.

JPEG compression is available only for image files that have millions of
colors or 256 grays or for CMYK files.

The TIFF Compression pop-up menu includes these options:

m None. Use this option if you don’t want any image compression applied to
the TIFF file.

m JPEG. Use this option to apply JPEG compression to the image saved as a
TIFF file. Not all programs that support TIFF support this option.

m LZW. Use this option if you want “lossless” compression, which means that
absolutely no image quality is sacrificed as a result of compression. LZW
compression is best for compressing 256-color (8-bit) images. If you
choose LZW compression for your TIFF image file, make sure that any
programs or remote computers that will need to open the file can work
with this compression format.

m PackBits is another form of “lossless” compression. The PackBits format is
best when used with black-and-white (1-bit) images.

If you choose JPEG, the JPEG controls become active. You can use these
controls to control the quality of the image and the amount of JPEG
compression. For details, see “Using JPEG Compression” later in this chapter.

JPEG

The JPEG file format is designed for use with JPEG compression, which
maintains optimal image quality for a given level of compression. This makes
the JPEG format ideal for for transferring image files via modem or over a
local area network.

JPEG compression is available only for image files that have millions of
colors or 256 grays or for CMYK files.
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For more information on the JPEG format, see “Using JPEG Compression”
later in this chapter.

EPS

EPS stands for Encapsulated PostScript. Many page layout programs support
this format for images placed or imported into a layout file. Like TIFF files,
EPS files include information about the file’s characteristics that allows many
different kinds of computers to open and interpret the color and image data
in the file. For example, personal computers running MS-DOS and UNIX
workstations can open and use image files saved in the EPS file format on a
Macintosh. (PC-DOS and UNIX workstations can’t display an EPS file’s
Preview image, however.)

An EPS file usually includes a Preview image, which is the image that
appears on your Macintosh screen when the file is placed or imported into a
page layout document that supports EPS files. The preview is only a screen
image, usually of lower resolution than the main image. When you print the
page layout document, the real image prints.

The Preview image data is separate from the image data of the EPS file itself.
Because the Preview image is a separate part of the image file, PhotoFlash
allows you to define the characteristics of the Preview image independently
from those of the rest of the EPS file.

The options that can be applied to an image file saved in the EPS format
appear in the Save As EPS dialog box. You can also choose to apply JPEG
compression to the file, in which case the JPEG compression controls become
active. For more information about the JPEG controls, see “Using JPEG
Compression” later in this chapter.
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You can use the three EPS Settings pop-up menus—Preview, Quality, and
Format—to define how PhotoFlash saves the image file in the EPS file
format. The sections that follow describe the settings for each.

Preview options

You use the Preview pop-up menu to select the number of colors you want for
the EPS file’s Preview image.

The Preview pop-up menu includes four options:

m None. Specifies that no Preview image will be saved with the EPS file.

m 1-bit PICT. Specifies a black-and-white Preview image. No colors or shades
of gray will appear in the Preview image.

m 8-bit PICT. Specifies a Preview image with 256 colors or shades of gray,
depending on the contents of the image.

m 24-bit PICT-JPEG. Specifies a Preview image with millions of colors
compressed using JPEG compression.
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Quality options

The Quality pop-up menu is available only if you’ve selected 24-bit PICT-
JPEG in the Preview pop-up menu.

You use the Quality pop-up menu to define the quality level of the JPEG
compression PhotoFlash applies to the Preview image saved with the EPS file.
You have three options: High, Medium, and Low. In most cases, the default
Medium setting is more than adequate for the Preview image.

Format options

You use the Format pop-up menu to specify the encoding PhotoFlash uses
when converting an image file to the EPS file format.

The Format pop-up menu includes three options:

m Binary. Use this option if you intend to use the image file only with
Macintosh computers. Binary is the most common type of EPS encoding,
and it is the default setting.

m ASCII 85. Use this option if your printer isn’t connected to your computer by
using an 8-bit channel such as LocalTalk or EtherTalk. The ASCII 85
encoding requires PostScript Level 2 devices. This setting increases the
size of the file by about 25 percent.

m ASCII Hex. Use this option if you intend to use the image file with a
computer other than your Macintosh and your printer uses PostScript
Level 1. This setting doubles the size of the file.

IMPORTANT An ASCII Hex file is about twice the size of an ASCII 85 file.
Use ASCII Hex only if it is absolutely required for using the EPS file with a
computer other than your Macintosh and you need to use PostScript Level 1.
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Depending on the type of image file that you are converting to the EPS file
format, the following limitations may apply:

m JPEG compression is available only for image files that are in millions of
colors, 256 grays, or the CMYK file format.

m You can print EPS JPEG files only on a PostScript Level 2 printer.

DCS

DCS stands for Desktop Color Separation. It is used in page layout and other
programs that can prepare color images for printing.

When you convert an image file to the DCS file format, PhotoFlash creates
five separate image files:

m Master file contains an image created for positioning in the page layout
program. This image file can be opened and reviewed; it represents the
content of the image. Its filename contains the suffix /DCS.

m Cyan contains the cyan components of the image file. Its filename includes
the suffix /DCS.C.

m Magenta contains the magenta components of the image file. Its filename
includes the suffix /DCS.M.

m Yellow contains the yellow components of the image file. Its filename
includes the suffix /DCS.Y.

m Black contains the black components of the image file. Its filename
includes the suffix /DCS.K.

For example, if you saved an image file named Bike in the DCS file format,
the five files would look like this on the desktop:.
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IMPORTANT Only image files that have been created or opened in a CMYK
format can be saved as DCS files by PhotoFlash. PhotoFlash can’t directly
convert RGB (red, green, blue) image files to a CMYK file format like DCS.
If the DCS menu item is dimmed in the Save As submenu, it means the image
file you’re attempting to convert is not in a CMYK format.

You can obtain Photoshop-compatible plug-in modules that allow you to
convert an image file to CMYK formats from within PhotoFlash. Such files
are usually used with the Export command in the File menu. Sometimes they
are used with the Save As command.

Because the DCS file format is a variation of the EPS file format, the settings
and controls that appear in the Save As DCS dialog box are the same as those
for EPS files. For more information about using these settings and controls,
see “EPS” earlier in this chapter.

Number of colors or grays supported by standard file formats

Some file formats limit the number of colors or shades of gray that images
saved in those formats can use. This table lists the number of colors or grays
that you can specify when converting image files to the standard file formats
supported by PhotoFlash.

Black 4 16 256 16 256 Thousands Millions CMYK
& white grays grays grays colors colors of colors of colors colors

PICT x x x x x x x x

PICT-JPEG x x

TIFF x x x x x x x x

TIFF-JPEG x x x

TIFF-LZW x x x x x x x x

JPEG x x x

EPS x x x x

EPS-JPEG x x x

DCS x

103Conver t ing and Compress ing F i les



Using JPEG compression

JPEG is a standard method for still image compression established by the
Joint Photographic Experts Group. It is designed to compress and decompress
digitized images while preserving maximum image quality. You can use JPEG
compression with a variety of file formats in addition to the standard JPEG
format. Many kinds of computers can send, receive, and display image files
saved in the standard JPEG format.

The JPEG method of compression systematically omits redundant
information from the image, deleting the portions of the image that aren’t
critical to human visual perception, and then applies a highly effective
compression technique to the remaining data. Although JPEG dramatically
reduces the size of the image file, it doesn’t necessarily change the quality of
the image when the file is decompressed. The effect on the image depends on
the level of JPEG compression you apply. At High quality settings, the change
is usually imperceptible. At progressively lower settings, the image quality
may degrade.

The JPEG method of compression specifies a mathematical formula, not a
specific program. Thus results can vary when using different programs to
apply JPEG compression. The PhotoFlash implementation of JPEG
compression is extremely accurate. If you use PhotoFlash to compress and
decompress images several times, the image may deteriorate in quality the
first few times, but after that the quality remains the same no matter how
many times you recompress it.

The way you use JPEG compression depends on your needs and work habits.
In general, it’s worth compressing all your images. Any loss in image quality
at the Excellent quality setting is usually imperceptible. If you don’t know
what an image will be used for in the future, use the Excellent setting. If an
image is 300 dpi or higher and you intend to print it, the High quality setting
is usually sufficient.
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Applying JPEG compression to the entire file

You can apply JPEG compression to PICT, TIFF, JPEG, or EPS files that use
256 grays or millions of colors, or to DCS or other CMYK files. You may also
be able to apply JPEG compression to other formats supported by Photoshop-
compatible plug-in modules.

To apply JPEG compression, begin by choosing from the Save As submenu
the name of the file format to which you want to convert an image (see steps
1 and 2 of “Converting Image File Formats” earlier in this chapter). After you
choose the file format, the Save As dialog box for that format appears, and
you can continue with these steps:

1 Activate the JPEG slider by choosing the appropriate JPEG command from the pop-up
menu or selecting the JPEG Compression checkbox.

If you chose Save As PICT, choose Photo–JPEG from the PICT Compression
pop-up menu. If you chose Save As Tiff, choose JPEG from the TIFF
Compression pop-up menu. If you chose Save As EPS or DCS, click the Use
JPEG Compression checkbox to select it.

The JPEG quality slider control becomes active.

2 Drag the Quality slider control to a numbered setting.

Qualities range from 1 to 100.

A setting of 1 offers the lowest image quality and the most compression
(smallest size of the image file).

A setting of 100 offers the highest image quality and the least compression
(largest size of the image file).

3 Click Save to close the Save As dialog box and continue the saving procedure.

The Save dialog box appears.
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4 Use the Save dialog box to name the file and select a location for it.

By default, PhotoFlash appends a suffix to the name of the file that reflects
the file format you selected.

5 Click Save.

PhotoFlash applies JPEG compression and saves the image file.

IMPORTANT Compressing an image with JPEG may change the appearance of
the image. To examine the appearance of the compressed file, you must close
and then reopen it. 

Applying different levels of JPEG compression within an image

In addition to applying one quality level of JPEG compression to an entire
image file, all the file formats except PICT allow you to apply JPEG
compression at a high-quality setting to a selected area of an image and at a
lower-quality setting for the rest of the image.

This can be useful when you’re trying to minimize an image file’s size without
sacrificing its quality. You can maintain high-quality compression for
important areas of the image while applying lower-quality compression to less
important areas. Once you’ve applied this double level of compression, the
same settings are applied whenever you compress the whole image at the
high-quality level of compression.

To apply different JPEG compression settings to two different parts of an
image, follow these steps:

1 Select the part of the image to which you want to apply JPEG compression with the
highest-quality setting (least image degradation).

For instructions on using the Selection tools, see Chapter 3, “Working With
Selections.”

Be sure to select the most important area of your image.

2 Choose Save As from the File menu and drag to the right to select the file format you
want to use from the Save As submenu.

The Save As dialog box for the format you chose appears.
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3 Activate the JPEG slider by choosing the appropriate JPEG command from the pop-up
menu or selecting the Use JPEG Compression checkbox.

If you chose Save As TIFF, choose JPEG from the TIFF Compression
pop-up menu.

If you chose Save As EPS or DCS, click the Use JPEG Compression checkbox
to select it. 

The JPEG controls become active.

4 Drag the Selected Area Quality slider to select a numbered setting.

This setting will be applied to the area that is currently selected in the image.

A setting of 1 offers the lowest image quality and the most compression
(smallest size of the image file).

A setting of 100 offers the highest image quality and the least compression
(largest size of the image file).

Alternatively, you can choose one of the options from the Selected Area
Quality pop-up menu.
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Note: If you use Storm Software’s PicturePress and have created custom
compression settings, they also appear in the Selected Area Quality pop-up
menu.

5 Choose a percentage from the Unselected Area Quality pop-up menu. 

PhotoFlash applies the Selected Area Quality percentage you choose to the
part of the image area that isn’t selected.

6 Click Save to close the Save As dialog box and continue the saving procedure.

The Save dialog box appears.

7 Use the Save dialog box to name the file and select a location for it.

By default, PhotoFlash appends a suffix to the name of the file that reflects
the file format you selected.

8 Click Save.

PhotoFlash applies JPEG compression to the selected and unselected areas
according to your settings and saves the image file.

IMPORTANT Compressing an image with JPEG may change the appearance of
the image. To examine the appearance of the compressed file, you must close
and then reopen it. 
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You can automate your work in PhotoFlash and other programs by recording
and running a script, which is a series of instructions written in a scripting
language such as AppleScript or UserTalk™.

For example, suppose you are a real estate agent and you’ve taken a series of
digitized pictures of some townhouses you’re trying to sell. Because all the
houses are tall and narrow, you had to rotate the camera 90 degrees to fit
them in. And because it was a bright day when you took the pictures, all of
them are a bit bleached out.

You can easily fix a single image with these problems by using commands in
the Image and Enhance menus. The Rotate command allows you to rotate an
image 90 degrees, and the Brightness/Contrast command allows you to
darken an image. If you create a catalog for the images and select all their
thumbnails, you can use the same commands to fix them all at once.

But suppose that in addition to fixing the images, you want to place each one
in a page-layout template you use to describe each house for customers. You
could manually place each image, but that would take a long time. Instead,
you can record a script that rotates an image, adjusts its brightness and
contrast, creates a new page in a page layout document, and places the image
on that page. You can then drag selected thumbnails over the script’s name in
the PhotoFlash script palette to run the script. PhotoFlash opens the image for
each selected thumbnail, rotates and darkens it, creates a new page in the
page layout document, and places the image on the page.
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You can record scripts to automate many such repetitive tasks. This chapter
describes how to record, run, and edit scripts.

To record and run scripts that control PhotoFlash, you must have AppleScript
installed in your system. If you use the Installer program to install PhotoFlash
according to the instructions in the first chapter of PhotoFlash Getting Started,
the AppleScript software is installed in your system automatically.

IMPORTANT When you launch PhotoFlash, you should see a Script menu in
the menu bar that includes the scripts that come with PhotoFlash. If the Script
menu is dimmed, AppleScript may not be installed correctly. If you didn’t use
the Installer program to install PhotoFlash, quit PhotoFlash and reinstall it
according to the instructions in PhotoFlash Getting Started.

For information about the scripts that come with PhotoFlash, open the file
named PhotoFlash™ Scripting Guide in the Advanced Scripting folder, which
is located inside the PhotoFlash Folder.

The Script palette and Script menu

You use the PhotoFlash Script palette to record, save, and run scripts or to
open them for editing. If the Script palette isn’t visible on your screen, choose
Show Script Palette from the Window menu to make it appear.
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Scripting with PhotoFlash

If you’re familiar with AppleScript, these may be the only instructions
you need. If you’re not familiar with AppleScript, you should also read
the rest of this chapter.

If several scripting languages are installed in your system, a pop-up
menu appears in the Script palette that lets you choose among them.

Recording and saving scripts

To record a script, click the Record button, perform the actions you
want to record, and click the Stop button. PhotoFlash prompts you to
save the script. Save it in the Scripts folder (in the PhotoFlash folder) or
a folder within the Scripts folder if you want its name to appear in the
Script palette and Script menu.

Running scripts and application programs

To run a script, do any of the following:

m Choose the name of the script from the Script menu.

m Double-click the name of the script in the Script palette.

m Select the script’s name in the Script palette and then click Run.

m Drag catalog thumbnails over the script’s name and release the
mouse button to run the script on those images.

You can use the same techniques to launch programs. If a program is
capable of opening an image and you drag and drop the image’s
thumbnail over the program’s name in the Script palette, the program
opens the image.

Editing and writing scripts

To edit a script, select its name in the Script Palette and click the Edit
button. PhotoFlash opens the script in the Script Editor, a program that
comes with AppleScript. You can also use the Script Editor to write
new scripts.

For more information about AppleScript, see the AppleScript Language
Guide and the AppleScript Scripting Additions Guide (Addison-Wesley).
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You can also run a script or launch a program by choosing its name from the
Script menu.

The contents of the Scripts folder (located inside the PhotoFlash Folder)
determines which scripts and programs are available from within PhotoFlash.
The names of folders, programs, scripts, or aliases to any of these appear in
both the Script palette and the Script menu. You can change this arrangement
at any time by activating the Finder and arranging the contents of the Scripts
folder to suit your own convenience.
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Recording and saving a script

Recording scripts is the fastest way to learn about PhotoFlash’s scripting
capabilities. Before you begin to experiment with recording, it’s a good idea to
use the Duplicate command to make a copy of the image you want to work
with, in case something goes wrong.

To record a script, follow these steps:

1 If the Script palette isn’t visible on your screen, choose Show Script Palette from the
Window menu.

If the Show Script Palette command is dimmed, you may be using a version
of system software that doesn’t support AppleScript, or you may not have
installed AppleScript correctly. See the beginning of this chapter for details.

2 Click the Record button.

In a few seconds the Apple icon at the left side of your computer’s menu bar
begins to flash, alternating with the recording icon.

This means AppleScript is ready to record your actions.

3 Perform the actions you want to record.

Start with something simple, like rotating or enhancing an image. After
you’ve recorded a few short scripts, try more complex tasks like converting
files or using several Image menu or Enhance menu commands in a row.

4 When you’re finished, click the Stop button.
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PhotoFlash displays the directory dialog box for saving a script. By default,
PhotoFlash saves scripts in the Scripts folder.

5 Use the directory dialog box to name the script and specify its location on your 
hard disk. 

If you want the script’s name to appear in the Script palette and the
Script menu, save it in the Scripts folder or a folder within the Script folder.
Folders within the Scripts folder appear as menu items with submenus in
the Script menu.

To try out the script you just recorded, open another image file to test it on
and choose the script’s name from the Script menu.

You don’t have to know how to read scripts to record and run them. But if
you’re curious, select the name of your recorded script in the Script palette
and click the Edit button. The Script Editor program that comes with
AppleScript opens the script so you can read or edit it. You can also use the
Script Editor to add or edit a description of what the script does.

For more information about editing scripts, see “Editing a Script” at the end
of this chapter.
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Running a script

If a script performs an action on the frontmost window, the action may differ
depending on whether the window contains a catalog or an image. For
example, a script that blurs a selected area of the frontmost window works
correctly if you run it while an image is frontmost, but generates an error
message if you try to run it while a catalog is frontmost.

Make sure you know what a script does before you use it. If you’re not sure,
select the script’s name in the Script palette and check the description at the
bottom of the palette. If you can’t see the description area, click the triangle in
the Script palette’s lower-left corner.

The first time you run a script, choose Duplicate from the File menu to create
a new untitled copy of the catalog or image you want to run the script on.
That way you won’t risk changing the original if something goes wrong.

To run a script, perform any of these actions:

m Choose the script’s name from the Script menu.

m Double-click the script’s name in the Script palette.

m Select the script’s name in the Script palette and then click the Run button.

m Drag selected thumbnails over the script’s name and release the mouse
button to run the script on the corresponding images.
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Running a script can cause actions in more than one program. For example,
you can run a script that makes a copy of an image file, saves the copy as a
TIFF file, and places the TIFF version of the image in a word-processing
document.

Launching application programs from PhotoFlash

In addition to scripts or aliases to scripts, programs or aliases to programs that
you save in the Scripts folder appear in the Script menu and the Script
palette. You can use the same techniques you use to run a script to launch a
program from within PhotoFlash:

m Choose the program’s name from the Script menu.

m Double-click the program’s name in the Script palette.

m Select the program’s name in the Script palette and then click the Run
button.

m Drag selected thumbnails over the program’s name until it becomes
highlighted and then release the mouse button to open the corresponding
images in the program. (If the program’s name won’t highlight, it can’t open
those images.)

Choosing a different scripting language

If you have installed more than one scripting language in your system, a pop-
up menu that allows you to switch between languages appears in the Script
palette below the Record button.
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Editing a script

This section describes a situation in which you might want to make a 
minor change to a recorded script and demonstrates how to edit the script
accordingly.

Suppose you have recorded a script that performs one or more actions on the
image in the frontmost window and then saves it. For example, Chapter 5 of
PhotoFlash Getting Started describes how to record a script that rotates an
image and then saves it as a TIFF file. If you saved that script in the Scripts
folder (inside the PhotoFlash folder), its name appears in the Script palette.

To edit any script whose name appears in the Script palette, follow these
steps:

1 Click the name of the script in the Script palette to select it.

2 Click the Edit button to open the script in the Script Editor application program.

The Script Editor program comes with AppleScript and is installed on your
hard disk when you install PhotoFlash.

Suppose that when you first created this script you saved it as a TIFF file
without any compression. Now, however, you want to change the script so that
PhotoFlash saves each image with JPEG compression.
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Of course, you could just record the script all over again, this time applying
JPEG compression. For a short script like this, rerecording is easy enough.
But rerecording longer scripts may take a long time. Another alternative is to
figure out which part of the script needs to be changed, then change just that
part.

The original script looks something like this:

Notice that the fourth line of the script is so long it disappears off the
right side of the screen and ends up wrapping around to the fifth line. To
see the rest of the fourth line, click in the scroll bar along the bottom of
the script’s window.

But what does it all mean? Don’t worry, you don’t need to know how the
whole script works. You just need to figure out how PhotoFlash describes
JPEG compression settings. Notice that the fourth line includes the words
|UseJPEG|:false. Maybe that has something to do with it.

The easiest way to find out for sure how PhotoFlash describes an action in a
script is to record the action. In this case, you need to figure out which part of
the script controls the compression settings. First open and duplicate an
image to use for recording purposes, then follow these directions:

1 Click the Record button in the Script Palette.

2 Choose Save As from the File menu, but don’t release the mouse button.

3 Drag to the right to choose TIFF from the Save As menu.

The Save As TIFF dialog box appears.

118 Chapter  7



4 Choose JPEG from the TIFF Compression pop-up menu.

5 Make sure the slider is set to 67, for high-quality compression.

The default setting is 67, so you shouldn’t have to adjust it.

6 Click Save.

The Save directory dialog box appears.

7 Use the directory box to name the image file and specify its location.

The new file is just a sample for recording purposes, so you can save
it anywhere.

8 Click Save.

9 Click the Stop button in the Script palette.

PhotoFlash displays the directory dialog box for saving a script.

10 Use the directory dialog box to name the script and specify its location.

Don’t save it in the Scripts folder. Save it somewhere else where you can find
it easily, such as the desktop. You won’t need the script for long.

Now you’ll use the Script Editor to open the script you just recorded so
you can compare it to the original Rotate and Save As TIFF script. Follow
these steps:

1 Activate the Finder and locate and double-click the script you just recorded.

The script opens in the Script Editor program.

To compare this script with the original script, open the original and arrange
the script windows on the screen so you can see them both. (The original
script is also reproduced earlier in this section.) Look for the part of each
script that comes after the words |Use JPEG|. You may have to use the
scroll bar at the bottom of each window to scroll until you can see this part of
the script. 
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When you look at the part of each script that follows |Use JPEG|, you’ll
notice that there’s only one difference. The original script says |Use
JPEG|:false, whereas the new one says |Use JPEG|:true. The rest of
that line in each script is identical. The original script shows the default slider
setting of 67, even though compression was turned off.

So, to change the original script so it saves images with JPEG compression set
to 67, all you need to do is change the word false to true.

2 Activate the window of the original Rotate and Save As TIFF script, double-click the word
false in the fourth line of the script to select the word, and type true.

3 Click the Check Syntax button or press Enter.

If you made a mistake in your typing, the Script Editor highlights it for you.
If this happens, correct the mistake and click Check Syntax again.

4 Choose Save from the File menu.

To test your changes, try using the script to rotate and save an image.

You can use the same technique whenever you’re in doubt about how to edit
part of a script. Just record the new behavior you want in a separate script,
compare the old script to the new one to identify the differences, and change
the corresponding place in your original script. 
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PhotoFlash allows you to change the default settings it uses for various
aspects of its operation, including virtual memory settings, thumbnail
size, and other preferences. This appendix explains how to change
PhotoFlash preferences and how different preference settings affect the
way PhotoFlash works.

In most cases the default settings work well for optimum performance. You
need to change them only if you have special needs.
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To examine or change any of the PhotoFlash preferences, choose Preferences
from the Edit menu. The Preferences dialog box appears.

Virtual memory preferences

PhotoFlash uses a technique called virtual memory to simulate RAM. This
allows it to work with files that are larger than the amount of RAM available
in your computer.

IMPORTANT PhotoFlash’s use of virtual memory is completely independent
from System 7’s use of virtual memory as shown in the Memory control
panel. For best results with all Macintosh computers other than Power
Macintosh computers, turn virtual memory off in the Memory control panel
when PhotoFlash is using its own virtual memory.

By default, PhotoFlash chooses the fastest hard disk drive connected to your
Macintosh to use for virtual memory. It also ignores drives that employ
removable media, such as hard disk cartridges, DAT (digital audio tape), or
magneto-optical discs. You may use removable drives for virtual memory if
you need more free space for large images, but you won’t be able to remove
the cartridges while PhotoFlash is using them.
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If you have several disk drives connected to your Macintosh, you may want to
specify one drive to be used for PhotoFlash virtual memory. The disk with the
greatest amount of free space would be a good choice.

The virtual memory settings appear in the upper-left corner of the
Preferences dialog box.

When it uses virtual memory, PhotoFlash

m Lists all nonremovable drives, such as hard disk drives, and defines their
default setting as on.

m Lists all removable drives and defines their default setting as off.

m Doesn’t list other storage volumes, such as servers or CD-ROM drives,
because they can’t be used for virtual memory.

m Uses the fastest hard disk drive before using any other drives for virtual
memory. Then it uses the next fastest, and so on.

m Uses the minimum amount of hard disk space it needs to run efficiently if
hard disk space is limited. If you have more disk space available,
PhotoFlash uses it to speed up its performance.

PhotoFlash uses hard disk space for virtual memory only temporarily. After
you quit the program, the extra space on your hard disk is available again for
your use.
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To change the default settings for PhotoFlash’s virtual memory, follow
these steps:

1 To ensure that a certain disk is not used for PhotoFlash virtual memory, click the disk’s
checkbox to deselect it.

2 Repeat step 1 to deselect any other disks that you don’t want PhotoFlash to use for
virtual memory.

3 Click OK to close the Preferences dialog box and save your settings.

IMPORTANT Once you deselect a hard disk drive that’s in use (shown in bold
type) and close the Preferences dialog box, you must quit PhotoFlash and
then launch it again to actually change the status of the hard disk drive.

The number of images that PhotoFlash can open is determined by the amount
of RAM assigned to it and the available disk space on the disks that are
selected in the Preferences dialog box. For example, if you leave none of the
disks selected, PhotoFlash can open only images that can fit in the unused
portion of its RAM partition.

Thumbnail preferences

PhotoFlash automatically creates a thumbnail when you save an image file
and saves it along with the image. Thumbnails appear in PhotoFlash’s Open
dialog box and in catalogs.

IMPORTANT The thumbnail is stored in a part of the image file that is separate
from the image itself. You can use images that have thumbnails with other
programs that don’t support thumbnails.
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The thumbnail settings appear in the lower-left corner of the Preferences
dialog box.

Small thumbnails are 80 x 80 pixels and large thumbnails are 128 x 128
pixels; both use millions of colors and medium-quality JPEG compression.
Small is the default setting and produces the best results in catalogs. You may
want to change the settings if you’re planning to use your images with other
programs that display large thumbnails.

If you have special needs, you can use the Custom setting to define the exact
size, number of colors, and compression settings that are applied to the
thumbnail stored with the image file.

You can set the size of custom thumbnails up to 512 x 512 pixels.

You can also set the number of colors that custom thumbnails use. The
greater the number of colors, the more disk space the thumbnails use. If you
choose millions of colors, you can choose a level of JPEG compression to
reduce the amount of disk space required for each thumbnail. High quality
means a small amount of compression, but the thumbnail image will be of the
highest quality. Low quality means a high level of compression with a
corresponding loss of quality.

These settings are dimmed until you
click the Custom radio button.
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Display preferences

The display preferences determine how PhotoFlash opens image files and the
background color for images when they’re open. The display preference
settings appear in the upper-right area of the Preferences dialog box.

By default, PhotoFlash opens image files at actual size (100%), with no
magnification or reduction. If you’re working with a large image on a small
screen, some of the image may not be visible. You can change the default
setting so that PhotoFlash scales the image to fit the screen. To do this, click
the Open to Fit on Screen button.

The background color is the color that appears if you delete or move part of
the image or if you enlarge the work area. For example, if you use the Move
and Rotate tools to reposition parts of the image, the background (behind the
image) will “show through.”

The default setting for the background color is white. You can change this
setting to any color that you want.

To change the background color, follow these steps:

1 Click the Background Color box.
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The Background Color dialog box appears.

2 Use the dialog box to select a background color.

The dialog box is the same as the one used to set the desktop color for the
Macintosh screen. It is explained in the Macintosh User’s Guide.

Note: The background color is behind your image. If you move or delete a
selected area of your image, the background shows through. The background
is different from the gray area that surrounds the image if an image’s window
is larger than the image’s work area. The gray area that surrounds the image is
always gray and can’t be changed.

3 When you’ve selected the color you want, click OK to close the dialog box and save
your selection.

Processing/Filing preferences

The processing/filing preferences appear on the right side of the Preferences
dialog box. These settings allow you to control the way PhotoFlash works
with image files.

When you open an image file that’s larger than the amount of RAM
PhotoFlash has available, PhotoFlash stores part of that file on the hard disk
drive it’s currently using for virtual memory. When you make changes to that
part of the image, those changes are made on the hard disk.
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You can use the Optimize When Not Busy checkbox to control the way
PhotoFlash changes the parts of files it keeps on disk.

If the Optimize When Not Busy checkbox is selected, you may hear your hard
disk drive whirring unexpectedly when you’re not using your computer for
any other tasks. The Optimize When Not Busy checkbox is selected by
default, because this setting permits PhotoFlash to work most efficiently. If
you don’t want PhotoFlash to use your hard disk drive while your system is
idle, click the Optimize When Not Busy checkbox to deselect it.

When you use the Copy command in PhotoFlash, the currently selected area
is copied to the Clipboard so that it can be pasted into a different file or
program. The Export Large Clipboard checkbox allows you to control
whether PhotoFlash can store very large images on the Clipboard by using
disk space temporarily.

When the Export Large Clipboard checkbox is not selected, you can switch
between PhotoFlash and other programs more quickly because large clipboard
images aren’t converted when you switch.

IMPORTANT Even if the Export Large Clipboard checkbox isn’t selected,
PhotoFlash always exports small Clipboard images (under 32K in size).

You can use the Default File Type pop-up menu to define the file format in
which to save images that have not already been saved in a particular file
format. Typically, a file is not saved in a particular format if you’ve opened it
using the New or Acquire commands or if you’ve opened a file format that
PhotoFlash can only read, such as Photo CD.
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If you choose the Ask setting, PhotoFlash prompts you to choose a file format
before it saves a file.

For information on converting file formats, see Chapter 6.

Units preferences

The units preferences appear on the right side of the Preferences dialog box.
These settings determine the units of measurement that PhotoFlash displays
at the bottom of the Tool palette.

Use the Horizontal and Vertical pop-up menus to choose the units of
measurement in which measurements of width and height appear.
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Pixels and picas are units of measure used frequently by people who work
with images. A pixel is a small dot of color. The shapes that appear on your
computer screen are made of pixels. If you set the unit of measure to Pixels,
PhotoFlash displays the horizontal and vertical dimensions of your image in
pixels, or dots. A pica is one-sixth of an inch and is typically used to measure
blocks of text. If you set the unit of measure to Picas, PhotoFlash displays
the horizontal and vertical dimensions of your image in units of one-sixth of
an inch.

Note: While it is possible to specify different units of measurement for
horizontal and vertical dimensions, it’s usually preferable to use the same unit
for both.

If you plan to place images in a page layout program, you can define the
column size and gutter size used by PhotoFlash when it displays the width of
an image in “columns.”

For example, suppose you are creating a newsletter in a page layout program,
and the newsletter is formatted in three columns.
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As shown in the diagram, the columns are columns of text, and the gutters are
the space between the columns. When PhotoFlash displays the width of an
image in columns, it includes the gutter width between columns.

To specify Column Size and Gutter Size settings, follow these steps:

1 Position the pointer over the Horizontal pop-up menu and drag to choose Columns.

2 Position the pointer over the Column Size pop-up menu and drag to choose the same
unit of measurement that you use in your page layout program.

3 Type the size of your column in the Column Size box.

The default is 3 inches. Click in the box and type the width you want.

4 Position the pointer over the Gutter Size pop-up menu and drag to choose the same unit
of measurement that you use in your page layout program.

5 Type the size of your gutter in the Gutter Size box..

The default is 0.25 inches. Click in the box and type the width you want.
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6 Click OK to save the preferences you’ve defined.

These settings remain in effect until you change them again. PhotoFlash saves
the settings when you quit and continues to use them the next time you
launch it.
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You can install Photoshop-compatible plug-in modules in the PhotoFlash
Plug-ins folder to extend PhotoFlash’s capabilities. A plug-in module is a
special file that conforms to Photoshop’s standard plug-in specifications.
Photoshop plug-in modules that use other specifications may not work with
PhotoFlash.

You can use four types of plug-in modules with PhotoFlash:

m Acquire plug-in modules allow you to import images from external devices
such as digital cameras or scanners.

m Export plug-in modules allow you to export images to output devices such as
certain high-quality printers..

m Filter plug-in modules add commands to the Enhance menu that you can use
to apply special effects to images.

m File format translator plug-in modules enable you to open and save images in
file formats that PhotoFlash doesn’t support.
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Installing and storing plug-in modules

When you install PhotoFlash according to the directions in PhotoFlash Getting
Started, the Installer places a Plug-ins folder in your PhotoFlash folder. Place
all plug-in modules you want to use with PhotoFlash (or aliases to them) in
the Plug-ins folder. You must quit PhotoFlash, then launch it again before it
can recognize a newly installed module.

If you remove plug-in modules or their aliases from the Plug-ins folder, they
are no longer available for use from within PhotoFlash.

Using plug-in modules

To use a plug-in module from within PhotoFlash, you must first determine
what kind of module it is:

m To use Acquire plug-in modules, choose Acquire from the File menu but
don’t release the mouse button. The Acquire submenu displays the names
of any plug-in modules you’ve installed that can acquire images. To learn
more about using Acquire plug-in modules, see Chapter 2, “Working With
Image Files.” The Acquire command is dimmed if you don’t have any
Acquire plug-in modules.

m To use Export plug-in modules, choose Export from the File menu but
don’t release the mouse button. The Export submenu displays the names of
any plug-in modules you’ve acquired that can export images. The Export
command is dimmed if you don’t have an image open in PhotoFlash or if
you don’t have any Export plug-in modules installed.

m To use Filter plug-in modules, choose the name of the module from the
bottom of the Enhance menu.

File format translator plug-in modules work transparently. When you choose
Open from the File menu, the Open dialog box appears, displaying all the
files PhotoFlash can open, including any supported by the currently installed
plug-in modules.
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If a file format translator plug-in supports writing as well as reading the
format, you can use the Save command to save images using that format as
you would with any other file. Likewise, when you choose Save As from the
file menu without releasing the mouse button, the Save As submenu displays
the names of all the file formats PhotoFlash can write, including any
supported by the currently installed plug-in modules.

Note: When you choose the Save command, there are some cases (discussed
in “Saving an Image” in Chapter 2) in which a Save As dialog box appears for
the default file type. If you wish, you can make the format your file format
translator creates the default file type. To do so, choose Preferences from the
Edit menu and change the file format in the Default File Type pop-up menu.

Scripting plug-in modules

Some plug-in modules support scripting and others do not. To fully support
PhotoFlash’s scripting interface, a plug-in needs to be modified by the
company that makes it.

To find out if your plug-in can be scripted, experiment with recording actions
you use it to perform, check its documentation, or contact the company that
sells the plug-in module  and ask whether it supports PhotoFlash’s scripting
interface.

Developers of plug-in modules who wish to make their products scriptable
should contact Developer Technical Support at Apple Computer, Inc.
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You can accelerate some aspects of PhotoFlash’s performance by installing
accelerator cards in your computer. Accelerators designed to accelerate
specific programs, such as PhotoFlash, Adobe Photoshop (2.0.1 and 2.5 or
higher), and Storm PicturePress, are sold by SuperMac Technology and
DayStar Digital™.

All of these accelerator cards feature two programmable digital signal
processors (AT&T DSP16A chips) that can process 60 to 80 million
instructions per second. The specific aspects of program performance
that these accelerator cards improve vary depending on the program.

Power Macintosh computers typically do not benefit from accelerator cards.
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PhotoFlash tasks that can be accelerated

Accelerator cards that use AT&T DSP16A chips can accelerate the following
operations in PhotoFlash:

m Resizing

m Blurring

m Sharpening

m Reading Photo CD files

m Reading and writing files in JPEG format

m Reading and writing files in EPS-JPEG format

m Reading files in TIFF-JPEG format

Using accelerator cards

To use an accelerator card, just activate it as described in the documentation
that comes with the card. After a card has been activated, PhotoFlash makes
use of it automatically.
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AppleScript A system extension that allows you to control programs with the
aid of scripts. The term AppleScript also refers to the AppleScript scripting
language, one of several scripting languages that can take advantage of the
capabilities provided by the AppleScript scripting extension.

catalog A PhotoFlash file that represents a collection of images. A catalog
doesn’t contain the actual image files that it represents. Instead, it contains a
small copy of each file, called a thumbnail, and keeps track of the file’s
location on disk. The arrangement of thumbnails in a catalog is completely
independent of the arrangement of the image files on your hard disk.

CMYK A method of representing colors in an image, typically used in the
printing industry, in terms of the relative proportions of Cyan, Magenta,
Yellow, and Black that each color contains.

DCS (Desktop Color Separation) 1.0 A variation of the EPS file format used by
page layout programs. It is also one form of CMYK file. An image stored in the
DCS 1.0 format is split into five separate image files: Four represent the Cyan,
Magenta, Yellow, and Black components, and the fifth shows how the whole
image looks and can be viewed from within a page layout program or from
within PhotoFlash.

EPS (Encapsulated PostScript) A file format used primarily to export image
files for use with page layout programs.
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JPEG (Joint PhotoGraphic Experts Group) A standard method of compressing
image files. You can apply JPEG compression to files saved in most of the
formats that PhotoFlash supports, including the JPEG file format.

Photo CD A file format used to save photographs on Kodak Photo CDs.
PhotoFlash can open Photo CD files but can’t save files in this format.

PICT The standard Macintosh format for image files. PICT files can also be
opened in the Windows environment if QuickTime is installed in the
Windows system.

pica A unit of measure that equals one-sixth of an inch, typically used to
measure blocks of text.

pixel A small dot of color on a computer screen.

plug-in module A special file that conforms to Adobe Photoshop’s standard
plug-in specifications. Plug-in modules stored in the Plug-ins folder inside the
PhotoFlash folder provide additional capabilities that you can use from within
PhotoFlash.

script A series of instructions written in a scripting language such as
AppleScript. When you run a script, AppleScript sends the instructions it
contains to one or more applications specified in the script, which perform
the tasks the script describes.

thumbnail A miniature representation of an image that appears in a catalog or
a dialog box.

TIFF (Tagged Image File Format) A file format for both Macintosh and MS-DOS
system software, commonly used to transfer files between systems.

virtual memory A technique that allows a program to use available space on
one or more hard disks as if it were RAM. PhotoFlash’s use of virtual memory
is completely independent from System 7’s use of virtual memory as shown
in the Memory control panel.For best results with all Macintosh computers
other than Power Macintosh computers, turn virtual memory off in the
Memory control panel when PhotoFlash is using its own virtual memory.

work area The total area of an image, including unused pixels (white by
default) around the edges of the image itself. You can use the Resize
command to change the dimensions of the work area.
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RGB values, adjusting 77–78
Rotate command (Image menu) 69–70
Rotate tool 67–68
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Save As command (File menu)
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Save command (File menu) 36–37
Script Editor program 117–120
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DeDust tool 86, 88–89

145Index



DeScratch tool 89, 91–92
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Lasso tool 45
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Rotate tool 67–68
Sharpen tool 84–86
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Zoom tool 30–32

U

Units preferences 129–132
Using Sketch command 

(Search menu) 19–20
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Window menu commands
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The Apple Publishing System
This Apple manual was written, edited, and produced on a desktop publishing system using
Apple Macintosh computers and QuarkXPress. Screen shots were created and modified with
system software, ExposurePro, Aldus SuperPaint, PhotoFlash, and Adobe Photoshop. Proof
pages were created on Apple LaserWriter printers and on QMS and Tektronix color printers.
Final pages were output directly to separated film on a PostScript™-driven imagesetter. 

Text type is Times®, display type is Helvetica® Narrow, and cover type is Apple Garamond,
Apple’s corporate font. Ornaments are custom symbols designed for Apple Computer. Some
elements, such as computer voice, are set in Apple Courier, a fixed-width font. 

PostScript, the LaserWriter page-description language, was developed by Adobe Systems
Incorporated.


